Project

General

Profile

Bug #22278

When a partition has never been run on, there's a problem printing to screen

Added by John Freeman 8 months ago. Updated 5 months ago.

Status:
Reviewed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/02/2019
Due date:
% Done:

100%

Estimated time:
Experiment:
-
Co-Assignees:
Duration:

Description

In order for DAQInterface to successfully capture signals (see Issue #22146), I discovered I had to get rid of the tee-ing of the output into the DAQInterface logfile. Instead, I switched to using tail -f on the logfile to get DAQInterfae to print its output to screen, cutting off the first 10 lines of output so that we don't recover the last 10 lines of a prior session. However, if the logfile doesn't exist (e.g., the partition's never been run on), there's unexpected behavior - output doesn't appear. Since this is a situation that will come up in the future, this should be fixed.

Associated revisions

Revision 02420de8 (diff)
Added by John Freeman 7 months ago

JCF: satisfy Issue #22278 by switching DAQInterface from an alias to a sourced script

Basically, since I use tail -f on the DAQInterface logfile to send
DAQInterface output to the screen, I need to both make sure that (A)
tail -f doesn't spit out the 10 lines of the previous DAQInterface
session, and (B) that in so doing, I don't suppress the first 10 lines
of DAQInterface output if I'm using a partition for the first time.

History

#1 Updated by John Freeman 7 months ago

  • Status changed from New to Resolved

This issue's resolved with commit 02420de84301f57fd48c07c16f123e1480afc6a9 on the branch feature/issue22278_dont_skip_first_ten_output_lines. To review it, confirm that at the head of develop, if you try running DAQInterface on a partition that you've never run it on before, that you don't see a message like the following:

DAQInterface in partition <N> launched and now in "stopped" state, listening on port <M>

where <N> is the new partition number, and <M> == 10000 + 1000*<N>. Instead, you'll have to look in the DAQInterface logfile, /tmp/daqinterface_$USER/DAQInterface_partition<N>log, to see this output.

Then delete this new logfile, /tmp/daqinterface_$USER/DAQInterface_partition<N>log, and confirm that at the head of the issue branch you see this output both in the logfile AND on screen.

#2 Updated by John Freeman 5 months ago

  • % Done changed from 0 to 100
  • Status changed from Resolved to Reviewed

Reviewed by Ron on Tuesday.



Also available in: Atom PDF