Project

General

Profile

Bug #22098

Problem running online monitors on mu2edaq12

Added by Eric Flumerfelt 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/08/2019
Due date:
% Done:

0%

Estimated time:
Co-Assignees:
Duration:

Description

. ./setupARTDAQDEMO

WARNING: PRODUCTS environment has changed from initial installation.
Product list /home/eflumerf/Desktop/artdaq-demo-base-v3_04_00/products:/cvmfs/fermilab.opensciencegrid.org/products/artdaq:/home/eflumerf/Desktop/artdaq-demo-base-v3_03_02/products:/home/eflumerf/Desktop/artdaq-demo-base-v3_03_00/products:/home/eflumerf/Desktop/artdaq-mrb-base/products:/home/eflumerf/Desktop/artdaq-product-build/products:/home/eflumerf/Desktop/mu2e-mrb-base/products:/mu2e/ups not found.
Error encountered when setting up product: mrb
ERROR: Version conflict -- dependency tree requires versions conflicting with current setup of product mrb: version v3_01_01 vs v3_00_11

MRB_PROJECT=artdaq_demo
MRB_PROJECT_VERSION=v3_04_00
MRB_QUALS=e15:s65:prof
MRB_TOP=/home/eflumerf/Desktop/artdaq-demo-base-v3_04_00
MRB_SOURCE=/home/eflumerf/Desktop/artdaq-demo-base-v3_04_00/srcs
MRB_BUILDDIR=/home/eflumerf/Desktop/artdaq-demo-base-v3_04_00/build_slf7.x86_64
MRB_INSTALL=/home/eflumerf/Desktop/artdaq-demo-base-v3_04_00/localProducts_artdaq_demo_v3_04_00_e15_s65_prof

PRODUCTS=/home/eflumerf/Desktop/artdaq-demo-base-v3_04_00/localProducts_artdaq_demo_v3_04_00_e15_s65_prof:/cvmfs/fermilab.opensciencegrid.org/products/artdaq:/home/eflumerf/Desktop/artdaq-demo-base-v3_04_00/products:/home/eflumerf/Desktop/artdaq-demo-base-v3_03_02/products:/home/eflumerf/Desktop/artdaq-demo-base-v3_03_00/products:/home/eflumerf/Desktop/artdaq-mrb-base/products:/home/eflumerf/Desktop/artdaq-product-build/products:/home/eflumerf/Desktop/mu2e-mrb-base/products:/mu2e/ups

The working build directory is /home/eflumerf/Desktop/artdaq-demo-base-v3_04_00/build_slf7.x86_64
The source code directory is /home/eflumerf/Desktop/artdaq-demo-base-v3_04_00/srcs
----------- check this block for errors -----------------------
Error encountered when setting up product: cetpkgsupport
ERROR: Version conflict -- dependency tree requires versions conflicting with current setup of product cetpkgsupport: version v1_14_01 vs v1_13_00
ERROR: setup B cetpkgsupport failed
ERROR: setup of required products has failed
Error encountered when setting up product: artdaq_mpich_plugin
ERROR: Version conflict -
dependency tree requires versions conflicting with current setup of product : full descriptions cetpkgsupport v1_13_00 -f NULL -z /home/eflumerf/Desktop/artdaq-demo-base-v3_03_02/products vs cetpkgsupport v1_14_01 -f NULL -z /cvmfs/fermilab.opensciencegrid.org/products/artdaq

Setting up the MRB environment again to ensure that MRB-based executables and libraries are used during running. <<<

The working build directory is /home/eflumerf/Desktop/artdaq-demo-base-v3_04_00/build_slf7.x86_64
The source code directory is /home/eflumerf/Desktop/artdaq-demo-base-v3_04_00/srcs
----------- check this block for errors -----------------------
Error encountered when setting up product: cetpkgsupport
ERROR: Version conflict -- dependency tree requires versions conflicting with current setup of product cetpkgsupport: version v1_14_01 vs v1_13_00
ERROR: setup -B cetpkgsupport failed
ERROR: setup of required products has failed
art -c /tmp/TransferInputShmem_eflumerf_0.fcl
bash: art: command not found
[eflumerf@mu2edaq12 artdaq-demo-base-v3_04_00]$

This is probably a setupARTDAQDEMO-forRunning kind of bug, and is also probably related to CVMFS...


Related issues

Is duplicate of artdaq - Bug #22155: quick-mrb-start.sh assumptions not working for sbndResolved03/18/2019

History

#1 Updated by Eric Flumerfelt 6 months ago

  • Status changed from New to Feedback

I have reproduced the problem on my machines, and it has to do with having products set up outside of the running environment (I setup mrb in my .bashrc, which sets up cetpkgsupport), and with multiple product areas having conflicting versions of a package marked current.

I do not think there's a programmatic solution right now, (other than possibly calling unsetup_all in setupARTDAQDEMO, which seems like overkill), but we should definitely keep an eye on installed product areas. I find this bash function useful:

function upslist {
    ups list -aK+:PROD_DIR_PREFIX $@
}

#2 Updated by Eric Flumerfelt 6 months ago

  • Status changed from Feedback to Resolved

See #22155

#3 Updated by Eric Flumerfelt 6 months ago

  • Related to Bug #22155: quick-mrb-start.sh assumptions not working for sbnd added

#4 Updated by Eric Flumerfelt 6 months ago

  • Related to deleted (Bug #22155: quick-mrb-start.sh assumptions not working for sbnd)

#5 Updated by Eric Flumerfelt 6 months ago

  • Is duplicate of Bug #22155: quick-mrb-start.sh assumptions not working for sbnd added


Also available in: Atom PDF