Project

General

Profile

Feature #21993

create a camapgin from ini

Added by Yuyi Guo 9 months ago. Updated 8 months ago.

Status:
Closed
Priority:
High
Target version:
Start date:
02/27/2019
Due date:
% Done:

100%

Estimated time:
6.00 h
Spent time:
Scope:
Internal
Experiment:
-
Stakeholders:
Duration:

Description

I used poms_client upload_wf that call the server code ini_to_campaign to create a campaign. The campaign was created fine, but the job_type and login/setup was created under samdev/production . I intended to create under samdev/analysis and the campaign was created in samdev/analysis.

History

#1 Updated by Yuyi Guo 9 months ago

I figured it out that was some left from last test that used samdev/production. If I have the job_type in production, it will ignore the same named job_type in analysis. I guess this is not a bug, but a feature. .

#2 Updated by Yuyi Guo 9 months ago

  • Tracker changed from Bug to Feature

I changed this ticket from "bug" to "feature". It is nice that we are getting the message back to the client as show below.
I tested with the campaign already in POMS and it will return the correct id. Could we also output the warning on campaigns that already in POMS just like the jobtype?

u'status: 201 Created'
u'message: '
[ u"Warning: LoginSetup 'yuyi2_login' already exists and will not change.",
u"Warning: JobType 'yuyi2_prod_muminus_0-2.0GeV_isotropic_uboone_jobtype' already exists and will not change."]
u'campaign_id: 3281'

#3 Updated by Vladimir Podstavkov 9 months ago

Sure, we can definitely do that. The only problem is - it might be too late as the campaign has been updated already.

#4 Updated by Stephen White 9 months ago

  • Assignee set to Vladimir Podstavkov

#5 Updated by Yuyi Guo 9 months ago

We discussed in today's meeting that if a campaign is already in poms, the API should warning the user just like the job_type without overwrite it. The API should provide an option for the user to override the campaign if the user requests.

I just found that the API return below info when a poms instance is not provided. Should it return an error because there is nowhere the campaign uploaded?
u'status: 201 Created'
u'message: OK'

#6 Updated by Vladimir Podstavkov 9 months ago

  • Status changed from New to Work in progress

#7 Updated by Yuyi Guo 9 months ago

Vladimir,

I talked with Marc about the updating a campaign definition that was used for submitting jobs in the past. He said that it was OK to update the existing definition because the submission details had kept in the DB.

Yuyi

#8 Updated by Vladimir Podstavkov 8 months ago

  • % Done changed from 0 to 90

#9 Updated by Vladimir Podstavkov 8 months ago

  • Estimated time set to 6.00 h

#10 Updated by Vladimir Podstavkov 8 months ago

  • % Done changed from 90 to 100

#11 Updated by Vladimir Podstavkov 8 months ago

  • Status changed from Work in progress to Resolved

#12 Updated by Stephen White 8 months ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF