Project

General

Profile

Bug #21918

DataLogger art processes "exited with code 131"

Added by Eric Flumerfelt almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
02/18/2019
Due date:
% Done:

0%

Estimated time:
Experiment:
-
Co-Assignees:
Duration:

Description

While not a very destructive error, it does create an error message. Ron and I determined that the cause was an insufficient default delay between SMEM::endOfData broadcasting the EndOfData Fragment and ShutdownArtProcesses being called.

Adjusting the default "expected_art_event_processing_time_us" parameter to 1s caused the error message to go away on ironwork.

The issue is simply that art has to close the data file before it can exit, which was taking ~0.3s, while SMEM was only giving it 0.1s. However, art handles the subsequent SIGQUIT correctly, and the only effect is the generation of the error message. With this change, the demo can run without any error messages at all.

History

#1 Updated by Eric Flumerfelt almost 2 years ago

Resolution on artdaq/bugfix/21918_SMEM_DataLoggerArtCode131

#2 Updated by Eric Flumerfelt over 1 year ago

  • Target version set to artdaq v3_06_00
  • Status changed from Resolved to Closed

The code on this branch had been merged at some point in the past, or an identical change was made elsewhere.

Also available in: Atom PDF