Project

General

Profile

Bug #21829

cetskelgen invoked on macOS produces deprecation warnings

Added by Kyle Knoepfel 10 months ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
02/04/2019
Due date:
% Done:

0%

Estimated time:
Duration:

Description

When invoking cetskelgen on macOS, the following warnings are emitted:

Devel::InnerPackage will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at /System/Library/Perl/5.18/Module/Pluggable/Object.pm, line 8.
Module::Pluggable::Object will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at /System/Library/Perl/5.18/Module/Pluggable.pm, line 5.
Module::Pluggable will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at ./cetskelgen, line 54.

The SciSoft team should either move to a different implementation so that Module::Pluggable is not necessary, or see if it is reasonable to ship the module with our distributions.



Also available in: Atom PDF