Project

General

Profile

Bug #21710

mrb v3_00_02 gitCheckout issue

Added by Ron Rechenmacher 7 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Target version:
-
Start date:
01/16/2019
Due date:
% Done:

100%

Estimated time:
1.00 h
Spent time:
Duration:

Description

Seems mrb gitCheckout is dropping "@[^ ]*" from the url argument.
V3_00_02 does not work while v2_00_02 does:

/home/ron/work/artdaqPrj/demo26-Jan2018-devel/srcs
mu2edaq01 :^) type mrb
mrb is /home/ron/work/artdaqPrj/demo26-Jan2018-devel/products/mrb/v3_00_02/bin/mrb
/home/ron/work/artdaqPrj/demo26-Jan2018-devel/products/mrb/v3_00_02/bin/mrb
--2019-01-16_14:28:53--
/home/ron/work/artdaqPrj/demo26-Jan2018-devel/srcs
mu2edaq01 :^) mrb gitCheckout -d artdaq_utilities ssh://p-artdaq-utilities@cdcvs.fnal.gov/cvs/projects/artdaq-utilities
Cloning into 'artdaq_utilities'...
fatal: No path specified. See 'man git-pull' for valid url syntax
ERROR: Unable to execute clone command: git clone ssh://p-artdaq-utilities artdaq_utilities
--2019-01-16_14:29:01--
/home/ron/work/artdaqPrj/demo26-Jan2018-devel/srcs
mu2edaq01 :^) unsetup mrb
--2019-01-16_14:29:08--
/home/ron/work/artdaqPrj/demo26-Jan2018-devel/srcs
mu2edaq01 :^) setup mrb v2_00_02
--2019-01-16_14:29:21--
/home/ron/work/artdaqPrj/demo26-Jan2018-devel/srcs
mu2edaq01 :^) mrb gitCheckout -d artdaq_utilities ssh://p-artdaq-utilities@cdcvs.fnal.gov/cvs/projects/artdaq-utilities
Cloning into 'artdaq_utilities'...
X11 forwarding request failed on channel 0
remote: Counting objects: 3742, done.
remote: Compressing objects: 100% (2213/2213), done.
remote: Total 3742 (delta 2187), reused 2605 (delta 1446)
Receiving objects: 100% (3742/3742), 2.38 MiB | 8.40 MiB/s, done.
Resolving deltas: 100% (2187/2187), done.
NOTICE: Adding artdaq_utilities to CMakeLists.txt file
--2019-01-16_14:29:44--

Related issues

Related to mrb - Bug #21597: Are there changes needed to run gitCheckout with mrb v2_00_01?Closed2018-12-20

History

#1 Updated by Kyle Knoepfel 7 months ago

  • Description updated (diff)

#2 Updated by Christopher Green 7 months ago

  • Estimated time set to 1.00 h
  • % Done changed from 0 to 100
  • Assignee set to Christopher Green
  • Status changed from New to Resolved

This was an unfortunate regression due to the fact that the fix for issue #21597 contained in v2_00_02 was never merged back into develop. This has now been fixed with v3_00_03, which is already installed on woof. Sorry for the inconvenience.

#3 Updated by Christopher Green 7 months ago

  • Related to Bug #21597: Are there changes needed to run gitCheckout with mrb v2_00_01? added

#4 Updated by Lynn Garren 6 months ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF