Project

General

Profile

Task #21465

tag dunetpc v07_12_00

Added by Christoph Alt about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Start date:
11/30/2018
Due date:
% Done:

0%

Estimated time:
Duration:

Description

David,

Please tag dunetpc v07_12_00.

Christoph

P.S.: I deactivated test_AdcRoiViewer since it was failing: https://cdcvs.fnal.gov/redmine/projects/dunetpc/repository/revisions/develop/entry/dune/DataPrep/Tool/test/CMakeLists.txt

History

#1 Updated by Christoph Alt about 1 year ago

Also, the c2 build fails because of an error in AdcRoiViewer_tool.cc: http://dbweb5.fnal.gov:8080/LarCI/app/ns:dune/storage/docs/2018/11/30/buildDUNE__4aOnrPS.log

#2 Updated by David Adams about 1 year ago

  • Status changed from New to Work in progress

I have tried to resolve the problems with AdcRoiViewer and am running test jobs with c2 and gcc.

#3 Updated by David Adams about 1 year ago

For gcc the build and test suceeded but c2 has these errors:

/nashome/d/dladams/dev/dudev02/workdir/srcs/dunetpc/dune/Protodune/singlephase/ProtoDUNEUnstableHVFilter_module.cc:154:62: error: comparison of constant 9999999999 with expression of type 'UInt_t' (aka 'unsigned int') is always false [-Werror,-Wtautological-constant-out-of-range-compare]
            if (fTimeRangeHigh < 1000000000|| fTimeRangeHigh > 9999999999 || fTimeRangeLow < 1000000000|| fTimeRangeLow > 9999999999 ) {
                                              ~~~~~~~~~~~~~~ ^ ~~~~~~~~~~
/nashome/d/dladams/dev/dudev02/workdir/srcs/dunetpc/dune/Protodune/singlephase/ProtoDUNEUnstableHVFilter_module.cc:154:121: error: comparison of constant 9999999999 with expression of type 'UInt_t' (aka 'unsigned int') is always false [-Werror,-Wtautological-constant-out-of-range-compare]
            if (fTimeRangeHigh < 1000000000|| fTimeRangeHigh > 9999999999 || fTimeRangeLow < 1000000000|| fTimeRangeLow > 9999999999 ) {
                                                                                                          ~~~~~~~~~~~~~ ^ ~~~~~~~~~~
/nashome/d/dladams/dev/dudev02/workdir/srcs/dunetpc/dune/Protodune/singlephase/ProtoDUNEUnstableHVFilter_module.cc:62:24: error: private field 'PrevRDTSTimeSec' is not used [-Werror,-Wunused-private-field]
                double PrevRDTSTimeSec;
                       ^
/nashome/d/dladams/dev/dudev02/workdir/srcs/dunetpc/dune/Protodune/singlephase/ProtoDUNEUnstableHVFilter_module.cc:63:24: error: private field 'RDTSTimeNano' is not used [-Werror,-Wunused-private-field]
                double RDTSTimeNano;
                       ^
4 errors generated.

I can
  • 1. Fix it
  • 2. Comment out the module
  • 3. Tag and build gcc only
  • 4. Wait

Any thoughts on how I should proceed?

#4 Updated by David Adams about 1 year ago

I have added the author of the module. Owen, this is blocking our release--please let us know how to proceed.

One problem is you compare with 9999999999 and the largest value is -1 --> 4294967295.

da

#5 Updated by David Adams about 1 year ago

I have removed the comparisons with 9999999999 and removed the declarations of unused members. If this is acceptable (and it compiles and tests), there is no need for anyone else to take action, i.e. I follow my option 1. Speak quickly if you want something else.

#6 Updated by Christoph Alt about 1 year ago

This is fine for me!

#7 Updated by David Adams about 1 year ago

Owen also ok'd the change. I have committed changes to dunetpc develop and am rerunning the test builds.

#8 Updated by David Adams about 1 year ago

Tests are failing with crash for c2. The problem is fetching the geometry service.

#9 Updated by David Adams about 1 year ago

At the (almosst) lowest level, I think the problem is local is null in a call to void geo::LocalTransformation<Matrix>::LocalToWorldVect(local, world).

Moving up the chain, there is a call from geo::GeoObjectSorterProtoDUNESP::SortAuxDets. The problem has to do with CRTs. I see Brian's name on the code and I have added him to this ticket.

I don't think this is a problem for me to resolve. It appears we cannot use the geometry service with c2. Should we wait for Brian of go with gcc only?

Note problem can be seen with

$MRB_BUILDDIR/dunetpc/bin/test_GeometryProtoDune

for c2 only.

da

#10 Updated by David Adams about 1 year ago

Brian says this is not his code. It looks like Andrew Olivier last worked on the CRT sorting. I add him to this ticket.

#11 Updated by Leigh Whitehead about 1 year ago

There was a problem with c2 and geometry back with the CVN before. We added an explicit include into the CMakeList to fix it. I wonder if the same will work here? I include a link to the commit diff from Christoph:

https://cdcvs.fnal.gov/redmine/projects/dunetpc/repository/revisions/c2b40307f3c1193e8c26a6adecb654cda9950b93/diff/dune/CVN/func/CMakeLists.txt

#12 Updated by David Adams about 1 year ago

I just rebuilt under c2 hoping problem might go away. It did not. I also confirmed I get a crash if I instantiate the service from lar rather than with the test code.

A fix just went in so that the tail correction is not applied in MC where it was causing a crash. I will include that.

I have added Tingjun and George to this ticket.

#13 Updated by David Adams about 1 year ago

Leigh: larcorealg_Geometry is already in the list of LIB_LIBRARIES for GeoObjectSorterProtoDUNESP.

All: Should we give up on c2 for this release or continue to delay?

da

#14 Updated by Andrew Olivier about 1 year ago

The feature I wanted GeoObjectSorterProtoDUNESP to add isn't working out, so I'm currently planning to remove it by Monday. Would it help if I remove it now? I would remove that file entirely and take it out of ProtoDUNEChannelMapAlg.cxx to use the old default channel sorting instead.

If I remove GeoObjectSorterProtoDUNESP today, we wouldn't be able to get CRT raw data compatible with the Geometry service in this version of dunetpc, but I don't think that is likely to affect anyone yet. I'm planning to move the feature I was trying to implement to the ProtoDUNE-SP CRTRawDecoder next week.

#15 Updated by David Adams about 1 year ago

If it is not working anyway, removal is fine for me.

#16 Updated by Andrew Olivier about 1 year ago

OK, I wrote feature/aolivier_remove_crt_geo_sorting to remove the feature that I think is causing this problem and put back the "normal" channel sorting algorithm. It builds on the dunegpvms which I think means gcc by default, but I don't know the procedure for testing something like this that could affect how the geometry is loaded. Please let me know what I need to do to test this change and let me know if you have any problems using it. I'm in a meeting on a weak wifi connection, so it might be about an hour before I can run any serious test jobs.

#17 Updated by David Adams about 1 year ago

Please put the change in develop. I will test as soon as this is done. I don't know how you set up, but replacing e17 with c2 switches from gcc to clang. Thanks.

#18 Updated by Tingjun Yang about 1 year ago

My understanding is that develop is fixed.

#19 Updated by David Adams about 1 year ago

You can test with $MRB_BUILDDIR/dunetpc/bin/test_GeometryProtoDune

#20 Updated by Andrew Olivier about 1 year ago

OK, develop of dunetpc builds for me on dunebuild01 with qualifiers debug:e17 and debug:c2, and the CI test looks OK. At the end, I got back:

test_GeometryDune: -----------------------------
test_GeometryDune: Done.
Tests concluded.
ArtServiceHelper::close: Closing art services.

For both of them, and no error messages stood out to me. This code is already committed to develop. Please let me know if you need me to do anything else.

#21 Updated by David Adams about 1 year ago

The latest dunetpc builds and tests successfully with both compilers. I have tagged and started the Jenkins builds.

#22 Updated by David Adams about 1 year ago

Th e17 builds are installed. Those for c2 will be installed after the mac builds complete.

#23 Updated by David Adams about 1 year ago

  • Status changed from Work in progress to Closed

This was completed yesterday.



Also available in: Atom PDF