Project

General

Profile

Bug #21341

INC000000993451 - Users crashing when changing campaigns - but logged into different experiment.

Added by Stephen White 10 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
11/09/2018
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
First Occurred:
Scope:
Internal
Experiment:
-
Stakeholders:
Duration:

Description

I lost track about this issue that affects users who are in multiple experiments.
I summarize below:

INC000000993451 -- When opening a link of a campaign of exp A, the exp of the login session reflects the previous session and not the actual link of the campaign, so it could be for example exp B.
This causes a crash while attempting to change a parameter of the campaign of exp A, because you are login into exp B according to POMS.
There is an issue of consistency.
In the SBN program is quite common that people are in two different experiments (at least), thus this issue has a probability >0.

Meanwhile this issues is addressed, could it be possible to have a useful error message helping the user to switch to the same exp as the link of the campaign opened?

Thanks,
Anna

History

#1 Updated by Stephen White 9 months ago

From RITM0747224.

Useful error message in case an experimentalist in multiple experiments open a POMS campaign link not matching with the exp POMS login of a previous session.
Please enter the details of your request here I'm opening this ticket per Steve request in RITM0745002.
Meanwhile INC000000993451 is addressed with Bug #21341 , could it be possible to have a useful error message helping the user to switch to the same exp as the link of the campaign opened?

#2 Updated by Vladimir Podstavkov 9 months ago

Steve,

Could you clarify how it is possible in the first place? The issue is about campaign link being opened by the user. Where does this link come from? I need to understand better the circumstances when it happens.

Vladimir.

#3 Updated by Vladimir Podstavkov 9 months ago

  • Status changed from New to Accepted

#4 Updated by Marc Mengel 7 months ago

So I think this happens as follows:

Open two browser windows.
In one switch to experiment 1 (ie. sbnd) and get a campaign_stage list
In the other switch to experiment 2 (i.e. dune) and get a campaign_stage list
Now go back to the first window, and click the link to a campaign stage.
You are now on an sbnd campaign stage, but with dune selected as your current
experiment.

Even worse, I think if you click through to the campaign stage page before
switching windows and experiments, if you swithch back to the first page, it
shows sbnd as your current experiment, even though it is now dune, since it
changed since we rendered the page...

Maybe if we pass an item_experiment value through to our page templates where possible, we could note if its different from the session one and highlight it?

#5 Updated by Vladimir Podstavkov 7 months ago

  • Estimated time set to 2.00 h
  • % Done changed from 0 to 80
  • Status changed from Accepted to Work in progress

#6 Updated by Vladimir Podstavkov 7 months ago

  • % Done changed from 80 to 100
  • Status changed from Work in progress to Resolved

#7 Updated by Stephen White 6 months ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF