Project

General

Profile

Bug #21317

ifdh startProject doesn't encode the project name correctly.

Added by Vito Di Benedetto 11 months ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
11/06/2018
Due date:
% Done:

0%

Estimated time:
Duration:

Description

Dominic B. from SBND have a SAM dataset definition named tp0.5_prodsingle_pi+_bnblike_newflux_gen
When he uses this in POMS/fife_utils as input for a campaign stage, ifdh tries to start a SAM project by using the command:

ifdh startProject sbndpro-test_TP0.5__g4__prodsingle_pi+_bnblike_newflux__21306_20181106_101654_4131836 sbnd tp0.5_prodsingle_pi+_bnblike_newflux_gen sbndpro sbnd

and he gets the following error mesagge:

Exception: http://samwebgpvm03.fnal.gov:8480/sam/sbnd/stations/sbnd/projects/name/sbndpro-test_TP0.5__g4__prodsingle_pi%2B_bnblike_newflux__21306_20181106_101654_4131836
HTTP-Status: 404
Error text is:
ProjectNotFound: Project 'sbndpro-test_TP0.5__g4__prodsingle_pi _bnblike_newflux__21306_20181106_101654_4131836' not found (https://samweb.fnal.gov:8483/sam/sbnd/api/projects/name/sbndpro-test_TP0.5__g4__prodsingle_pi%20_bnblike_newflux__21306_20181106_101654_4131836?format=protobuf)

Here the project name is reported as

sbndpro-test_TP0.5__g4__prodsingle_pi _bnblike_newflux__21306_20181106_101654_4131836

note here pi+ has been replaced by pi followed by a space compared to the original project name passed as argument to ifdh startProject

Is it possible to get ifdh handle those special characters in project name?

History

#1 Updated by Marc Mengel about 1 month ago

  • Status changed from New to Rejected

I'm unable to reproduce this with the current ifdh and sam station; and ifdh hasn't changed how it escapes things since 07/20/2016...
(see: https://cdcvs.fnal.gov/redmine/projects/ifdhc/repository/revisions/pybind11/annotate/ifdh/ifdh.cc#L473 )

See for example
"http://samwebgpvm03.fnal.gov:8480/sam/samdev/stations/samdev/projects/name/abc%2Bdef%2Bxx"

   46  EXPERIMENT=samdev ifdh startProject abc+def+xx samdev foo+bar+baz mengel samdev 
   47  ifdh establishProcess "http://samwebgpvm03.fnal.gov:8480/sam/samdev/stations/samdev/projects/name/abc%2Bdef%2Bxx" demo demo bel-kwinith.fnal.gov mengel demo "test project with plus in name" 2 
   48  ifdh getNextFile ""http://samwebgpvm03.fnal.gov:8480/sam/samdev/stations/samdev/projects/name/abc%2Bdef%2Bxx" 93044
   49  ifdh getNextFile "http://samwebgpvm03.fnal.gov:8480/sam/samdev/stations/samdev/projects/name/abc%2Bdef%2Bxx" 93044
   50  ifdh endProject "http://samwebgpvm03.fnal.gov:8480/sam/samdev/stations/samdev/projects/name/abc%2Bdef%2Bxx" 
   51  history


Also available in: Atom PDF