Project

General

Profile

Bug #21239

PMT Host != localhost fails to boot

Added by Eric Flumerfelt 9 months ago. Updated 6 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
artdaq-daqinterface
Target version:
-
Start date:
10/26/2018
Due date:
% Done:

0%

Estimated time:
Experiment:
-
Co-Assignees:
Duration:

Description

I have found that setting PMT host to anything other than localhost fails to boot in artdaq v3_03_01.

Associated revisions

Revision 5fcc614b (diff)
Added by John Freeman 6 months ago

JCF: since it doesn't appear to be possible to launch pmt.rb remotely (see Issue #21239), throw an exception if users attempt to select anything other than the host DAQInterface is running on for the pmt.rb host

History

#1 Updated by Eric Flumerfelt 9 months ago

  • Project changed from artdaq to artdaq Utilities
  • Category set to artdaq-daqinterface

#2 Updated by John Freeman 6 months ago

This also doesn't work at the command line, at least using the same technique DAQInterface is attempting. E.g., say that on mu2edaq01 I try the following:

ssh -f mu2edaq06 ". /cvmfs/fermilab.opensciencegrid.org/products/artdaq/setup ; source /home/jcfree/artdaq-demo_dec19/setupARTDAQDEMO ; which pmt.rb ; pmt.rb -p 11001 -d /tmp/pmtConfig.79663 --logpath /home/jcfree/daqlogs --logfhicl /tmp/messagefacility_partition1_jcfree.fcl --display $DISPLAY &" 

...where all the processes listed in mu2edaq06:/tmp/pmtConfig.79663 are given the host mu2edaq06 to run on. If, after running this ssh command, I log into mu2edaq06, what I find is that (A) no artdaq processes are running, and (B) the pmt logfile is empty.

Unclear what's happening, but for the time being, I'm having DAQInterface throw an exception if a user requests that pmt.rb run on anything other than the localhost (develop branch commit 5fcc614bed6796ef6839d0afcd726ed17200d083).



Also available in: Atom PDF