Project

General

Profile

Bug #20988

For proxy created by using the kcron principle jobsub_client believes it is not valid too early

Added by Vito Di Benedetto about 1 year ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
JobSub Client
Target version:
Start date:
10/01/2018
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

I got jobsub_client throwing the following error message:

ERROR
Your user proxy, /data/CI/users/vito/vito.genie.Analysis.proxy has DN=/DC=org/DC=cilogon/C=US/O=Fermi National Accelerator Laboratory/OU=Robots/CN=larsoftdev6.fnal.gov/CN=cron/CN=Vito Di Benedetto/CN=UID:vito/CN=34945241/CN=3459365617/CN=1089854870
 .  This probably means voms-proxy-init has been used to refresh it too many  times.  The easist way to fix the problem is to remove the file /data/CI/users/vito/vito.genie.Analysis.proxy and re-create it. The easiest way to re-create it is to re-submit your job after removing the file.

In this case the DN

/DC=org/DC=cilogon/C=US/O=Fermi National Accelerator Laboratory/OU=Robots/CN=larsoftdev6.fnal.gov/CN=cron/CN=Vito Di Benedetto/CN=UID:vito/CN=34945241/CN=3459365617/CN=1089854870

has only 3 groups 'CN=[:digits:]' and the proxy should still be valid.

While the proxy with this DN

/DC=org/DC=cilogon/C=US/O=Fermi National Accelerator Laboratory/OU=People/CN=Vito Di Benedetto/CN=UID:vito/CN=2640249738/CN=3848443316/CN=885198316/CN=3257970140

that has 4 groups 'CN=[:digits:]' can be used as it is still valid and jobsub_client doesn't complain.

As discussed with Shreyas this could depend on the other 'CN' elements in the DN.

History

#1 Updated by Dennis Box 6 months ago

  • Target version set to v1.3
  • Assignee changed from Parag Mhashilkar to Dennis Box
  • Status changed from New to Work in progress

#2 Updated by Dennis Box 6 months ago

  • Status changed from Work in progress to Feedback

Tested with VerifyDepth=10, please review branch 20988

#3 Updated by Dennis Box 6 months ago

  • Assignee changed from Dennis Box to Shreyas Bhat

#4 Updated by Shreyas Bhat 6 months ago

  • Assignee changed from Shreyas Bhat to Dennis Box
  • Status changed from Feedback to Accepted

Yep - looks good to me.

#5 Updated by Dennis Box 5 months ago

  • Status changed from Accepted to Resolved


Also available in: Atom PDF