Project

General

Profile

Support #20847

problem with handling '--estart' / '-e' options in art 2.10.04 (Mu2e flavor)

Added by Pavel Murat about 1 year ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Event Loop
Target version:
Start date:
09/15/2018
Due date:
% Done:

100%

Estimated time:
4.00 h
Scope:
Internal
Experiment:
Mu2e
SSI Package:
art
Duration:

Description

'mu2e -e 100 ...' or 'mu2e --estart 100'

starts processing a file, containing events with numbers starting from 1, from the very first event, event_number=1,
not from the one with event number=100

'-e' option has been handled properly by previous versions of art.
It is a very handy option, would be nice to have it back.

-thanks, Pasha


Related issues

Is duplicate of art - Support #7308: -e/--estart command line option not workingClosed11/11/2014

History

#1 Updated by Kyle Knoepfel about 1 year ago

  • Category set to Event Loop
  • Status changed from New to Assigned
  • Assignee set to Kyle Knoepfel
  • Estimated time set to 4.00 h

We will investigate.

#2 Updated by Kyle Knoepfel about 1 year ago

  • Status changed from Assigned to Feedback

I am having trouble reproducing the problem with art 2.10.04. For example:

[knoepfel@woof ~]$ setup art v2_10_04 -q e15:prof
[knoepfel@woof ~]$ art -c /dev/null -n 200 -o out.root

Make sure the right number of events is in the file

[knoepfel@woof ~]$ count_events --hr out.root
out.root        1 run, 1 subrun, 200 events, and 0 results.
Counted events successfully for 1 specified files.

Now try to start processing at event number 100.

[knoepfel@woof ~]$ art -c /dev/null out.root -e 100
...
Begin processing the 98th record. run: 1 subRun: 0 event: 197 at 18-Sep-2018 15:07:15 CDT
Begin processing the 99th record. run: 1 subRun: 0 event: 198 at 18-Sep-2018 15:07:15 CDT
Begin processing the 100th record. run: 1 subRun: 0 event: 199 at 18-Sep-2018 15:07:15 CDT
18-Sep-2018 15:07:15 CDT  Closed input file "out.root" 

TrigReport ---------- Event  Summary ------------
TrigReport Events total = 101 passed = 101 failed = 0

which demonstrates correct behavior (at least for the default settings).

Can you provide a configuration/input file that demonstrates the failure you've encountered?

#3 Updated by Kyle Knoepfel about 1 year ago

  • Is duplicate of Support #7308: -e/--estart command line option not working added

#4 Updated by Kyle Knoepfel about 1 year ago

I confirm that the desired behavior does not happen if the Run and SubRun numbers are not 1 and 0, respectively. Please see the related issue #7308--it is time for us to resolve this infelicity. We will schedule its resolution for the next minor release of art.

#5 Updated by Kyle Knoepfel about 1 year ago

  • Target version set to 3.02.00

#6 Updated by Kyle Knoepfel about 1 year ago

  • Tracker changed from Bug to Support

#7 Updated by Kyle Knoepfel about 1 year ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

See the notes for feature #9594.

#8 Updated by Kyle Knoepfel 10 months ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF