Project

General

Profile

Support #20406

System behaving unexpectedly when there are no triggers

Added by Kurt Biery 12 months ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
07/23/2018
Due date:
% Done:

0%

Estimated time:
Experiment:
-
Co-Assignees:
Duration:

Description

A message from Roland Sipos on the protoDUNE DAQ Slack channel:

I was running on Partition2, without enabling any triggers.
After 10 minutes,  the BoardReader's trigger matching mechanism activated, meaning that I receive trigger requests on our ZMQ connection out configuration in np04_WibsFake_Ssps00010.
I don't think, this is the expected thing

I'm not sure that I fully understand what Roland is describing, and I haven't taken time to look at the log files, but I wanted to capture this trouble report for later follow-up.

History

#1 Updated by Kurt Biery 12 months ago

This may not be related to artdaq.

It may be caused by partition cross-talk in the ZeroMQ trigger messages sent out by the Timing FragGen.

It sounds like there have been changes in Run Control and DAQInterface to help prevent cross-talk between partitions in this area.

#2 Updated by Kurt Biery 12 months ago

  • Status changed from New to Resolved

It sounds like a fix in the FELIX FragmentGenerator code fixed this.



Also available in: Atom PDF