Project

General

Profile

Bug #20306

Session_experiment is changed from under user.

Added by Stephen White over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
07/12/2018
Due date:
% Done:

0%

Estimated time:
First Occurred:
Scope:
Internal
Experiment:
-
Stakeholders:
Duration:

Description

From RITM0699449. See that request for the image Gianluca Petrillo uploaded.

When accessing POMS dashboard, I can see only SBND campaigns, despite the fact that I have Analyzer role also in other VO's (including a production role in ICARUS). Furthermore, the only VO listed for me is ICARUS, and there are no roles at all listed.
I log in when requested with my service password. The browser does not ask for any certificate.
Attaching a screenshot of POMS campaign stage list.

This appears to be related to seeing the infrequent issue of the session_experiment being changed to a different experiment when the user changes forms.


Related issues

Related to Production Operations Management Service (POMS) - Feature #20654: Users should be able to *view* anything in their experiment, but only *change* things they have the role forClosed08/21/2018

Related to Production Operations Management Service (POMS) - Feature #20655: Allow users with Analysis role into POMSClosed08/21/2018

History

#1 Updated by Marc Mengel over 1 year ago

So this is actually about 3 issues:
1) User wants to be able to see experiment Production for experiments they have Analysis role on.
2) Adding users with Analysis role to POMS at all
3) experiment/role switching out from under you

Since the title of the issue is related to the last item, we'll keep that on here and add related issues
for the other two.

#2 Updated by Marc Mengel over 1 year ago

  • Related to Feature #20654: Users should be able to *view* anything in their experiment, but only *change* things they have the role for added

#3 Updated by Marc Mengel over 1 year ago

  • Related to Feature #20655: Allow users with Analysis role into POMS added

#4 Updated by Marc Mengel over 1 year ago

THe current theory on this is that we are currently running 6 processes of 8 threads each for POMS,
but using in-memory sessions. So if you land on a different process (rather than on another thread
of the same process) you get a different session, and thus your role/experiment info can change out from under you.

In the long term, we hope to drop sessions altogether, but for the next release I'm planning to move to one process and 30 or so threads, as we will have far fewer updates from agents to process; this should get
rid of us losing/resetting session info.

#5 Updated by Gianluca Petrillo over 1 year ago

The issue is resolved now. Thank you.

#6 Updated by Stephen White about 1 year ago

  • Status changed from New to Closed
  • Target version deleted (v4_1_0)


Also available in: Atom PDF