Project

General

Profile

Feature #20272

Support entry random access within one file?

Added by Herbert Greenlee almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
07/03/2018
Due date:
% Done:

100%

Estimated time:
Scope:
Internal
Experiment:
MicroBooNE
SSI Package:
Duration:

Description

Currently, the gallery Event interface supports only two file positioning methods:

void toBegin();
void next();

It also supports various informational methods, such as

bool atEnd() const;
long long eventEntry() const;

Is there any reason gallery Event couldn't support random access to a particular entry within the currently open file, e.g.

void prev();
void toEventEntry(long long);

This would come in very handy.


Related issues

Is duplicate of gallery - Feature #15853: Feature Request: previous and goToEvent functions in gallery::EventClosed03/13/2017

Has duplicate gallery - Support #21596: Allow random access to artroot events via galleryClosed12/20/2018

History

#1 Updated by Kyle Knoepfel almost 2 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

This facility is already provided in gallery versions 1.04 and newer. See the release notes here.

#2 Updated by Kyle Knoepfel almost 2 years ago

  • Related to Feature #15853: Feature Request: previous and goToEvent functions in gallery::Event added

#3 Updated by Kyle Knoepfel almost 2 years ago

  • Related to deleted (Feature #15853: Feature Request: previous and goToEvent functions in gallery::Event)

#4 Updated by Kyle Knoepfel almost 2 years ago

  • Is duplicate of Feature #15853: Feature Request: previous and goToEvent functions in gallery::Event added

#5 Updated by Kyle Knoepfel over 1 year ago

  • Has duplicate Support #21596: Allow random access to artroot events via gallery added


Also available in: Atom PDF