Project

General

Profile

Bug #20154

Hourly and daily averages are low in MADC burst driver

Added by Richard Neswold over 1 year ago. Updated 29 days ago.

Status:
Closed
Priority:
Normal
Start date:
06/12/2018
Due date:
% Done:

0%

Estimated time:
Duration:

Description

Jerry Annala reports:

I noticed something that took me a while to figure out, even though I think the problem seems to be very simple. The D:POTDAY value is most often smaller than the value you would get by integrating the POTMIN value over 24 hours. It turns out that I think what is happening is that you are only adding up the previous 23 hours instead of 24. When you get time, can you look at what the algorithm is doing and see if you think you agree.

The other parameters all look spot on.

History

#1 Updated by Richard Neswold over 1 year ago

  • Status changed from Assigned to Feedback

Proposed fix: b3a97026

I think the problem is that I checked for the top-of-the-hour before I updated the top-of-the-minute calculation. Now the driver processes the full, 60-minutes of samples before updating the hourly and daily averages. The front-end needs to be rebooted to get the new driver.

#2 Updated by Richard Neswold about 1 year ago

Does the calculation seems better? (I know it's hard to tell during the shutdown, but it ran for almost a month before.)

#3 Updated by Richard Neswold 29 days ago

  • Status changed from Feedback to Closed

No feedback. Closing this issue for now (the new driver has been running for a year without complaints.)



Also available in: Atom PDF