Project

General

Profile

Bug #20075

artdaqDriver config by partition folder requires right user permissions

Added by Wesley Ketchum over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Known Issues
Target version:
Start date:
05/31/2018
Due date:
% Done:

0%

Estimated time:
Experiment:
-
Co-Assignees:
Duration:

Description

Hi all,

By default, running icarus-artdaq with artdaqDriver, I get this error:

Failed to parse the configuration file '/tmp/partition_0/artConfig_0_1527794202506319.fcl' with exception
---- Can't locate or can't open specified file: BEGIN
/tmp/partition_0/artConfig_0_1527794202506319.fcl => /tmp/partition_0/artConfig_0_1527794202506319.fcl
---- Can't locate or can't open specified file: END

Art has completed and will exit with status 90.

I think the art thread on the event builder part wants to put a fcl file in a folder in tmp. The problem is that I can't guarantee write permissions to that folder if someone else made it. We should not have this be in a folder? Just put partition_0 in the name?

History

#1 Updated by Eric Flumerfelt over 2 years ago

  • Status changed from New to Resolved

Resolved by 0836e918. The reason it is a directory is so that all related art configurations are in one directory for troubleshooting, and to minimize the distance between the start of the art command and the partition number.

The commit simply makes sure that the mkdir sets the permissions on that directory to 0777.

#2 Updated by Eric Flumerfelt over 2 years ago

  • Category set to Known Issues
  • Status changed from Resolved to Closed
  • Assignee set to Eric Flumerfelt
  • Target version set to artdaq v3_02_01

Also available in: Atom PDF