Project

General

Profile

Bug #19890

art requires dictionary for non-persistent product

Added by Raymond Culbertson over 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
05/04/2018
Due date:
% Done:

100%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
Mu2e
SSI Package:
art
Duration:

Description

In a producing service, I declare a product:

produces<mu2e::myProduct,art::InSubRun>("", art::Persistable::No);

I do not add the class to classes_def.xml since I should not need
to make a dictionary, but I get an error:

---- LogicError BEGIN
NoDictionary: Could not find dictionary for: std::vector<mu2e::myClass>
despite passing runtime dictionary checks.

My understanding is that this error is not the expected behavior.

History

#1 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from New to Accepted

This behavior was not intentional. For the time being, adding a persistent="false" tag to the selections XML file should be sufficient. The long-term solution involves removing some dependence of framework infrastructure on ROOT.

#2 Updated by Kyle Knoepfel 10 months ago

  • Category set to Infrastructure
  • Status changed from Accepted to Resolved
  • Target version set to 3.02.00
  • % Done changed from 0 to 100

This issue has been resolved with the separation of art into art and art_root_io for art 3.02.00.

#3 Updated by Kyle Knoepfel 7 months ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF