Project

General

Profile

Bug #19773

ghost from fhicl prolog

Added by Andrei Gaponenko over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Low
Target version:
Start date:
04/19/2018
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
Duration:

Description

Hello,

Consider the following fcl file

BEGIN_PROLOG
mu2e.nested.block: { a: {} }
END_PROLOG

process_name: fcltest
somevar: { @table::mu2e.nested.block }

Once its parsing is finished, the top level "mu2e" variable should not exist, because it is a prolog variable. However "art --debug-config ..." shows, among other things, a

mu2e: {
   nested: {}
}

This does not break things, just looks wrong and somewhat confusing.

Andrei

Associated revisions

Revision 453f3666 (diff)
Added by Christopher Green over 1 year ago

Tests and fix for issue #19773.

Revision b44d9536 (diff)
Added by Christopher Green over 1 year ago

Tests and fix for issue #19773.

History

#1 Updated by Kyle Knoepfel over 1 year ago

  • Project changed from art to fhicl-cpp
  • Status changed from New to Accepted
  • Assignee set to Christopher Green
  • Estimated time set to 2.00 h
  • Scope deleted (Internal)
  • Experiment deleted (-)

#2 Updated by Christopher Green over 1 year ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

Fixed with commits b44d953 (develop) and 453f366 (art-v2-develop).

Prolog entries in dotted notation were not correctly marked with in_prolog due to limitations in the implementation of intermediate_table. This has been corrected and regression tests are in place.

Note that the behavior when prolog entries were nested was and remains correct.

#3 Updated by Kyle Knoepfel over 1 year ago

  • Target version set to 2.11.02

#4 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF