Project

General

Profile

Feature #19596

Remove "delete issue" link/icon

Added by Richard Neswold over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
04/06/2018
Due date:
% Done:

0%

Estimated time:
Duration:

Description

Today I added a comment to a resolved issue which really didn't add anything to the discussion so I clicked on the trashcan icon ... except I clicked on the issue's trashcan, which is placed way too close to the comment's trashcan. I clicked to confirm (without carefully reading what was being deleted) and now the issue is gone. The Redmine project is still following the outdated philosophy that deleting something actually deletes it from the database so there is no easy way to recover the data. Is it possible to (and do others agree we should):

  • Remove the trashcan icon from the issues pages? The idea being, if an issue is not longer useful, just add a comment and close it out rather than delete it from the system.

or

  • Remove the set of issue icons from the bottom of the page so that they only appear at the top, where all the issue details reside. I did have a situation where I wanted to edit a comment, but I clicked on the issue's edit icon (fortunately that one's easy to recover from.)

I've been using Redmine since 2011 and never had problems (until this one.) But we're starting to encourage others to use it and not everyone is motivated to use formal processes. So I can see, in the future, the potential for data loss from people mechanically using the system and making mistakes.

History

#1 Updated by Marc Mengel over 1 year ago

Well, you only see that 'cause you're a Manager on the project. regular "Developer" users cannot delete issues, nor do they see a button for it.

We could disallow Managers from deleting issues, too, but then you would have to put in a servicedesk ticket to delete them...

#2 Updated by Marc Mengel over 1 year ago

Rereading your ticket, we could hide the second set of buttons... I think..

#3 Updated by Richard Neswold over 1 year ago

Ah, so only managers can delete. Good to know. I'll adjust our assignments to minimize data loss.

I still think the links at the bottom cause more confusion than convenience.

#4 Updated by Marc Mengel over 1 year ago

What if we just added some separation between the issue edit/delete buttons and the issue one? one or two horizontal bars or something? would that be enough to resolve the confusion? I think I could even sell that patch upstream so we wouldn't have to track it locally...

#5 Updated by Richard Neswold over 1 year ago

That would help. Thanks.

#6 Updated by Marc Mengel over 1 year ago

Cut upstream issue 28514 , added patch to local Redmine.

#7 Updated by Marc Mengel over 1 year ago

  • Status changed from New to Resolved


Also available in: Atom PDF