Project

General

Profile

Bug #19465

Branches created for dropped products

Added by Raymond Culbertson over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
03/22/2018
Due date:
% Done:

100%

Estimated time:
Spent time:
Occurs In:
Scope:
Internal
Experiment:
Mu2e
SSI Package:
art
Duration:

Description

With
FN=/pnfs/mu2e/persistent/users/mu2epro/valjob/digi/04/dig.rlc.val-ceMixDigi.2018-03-16.004001_00000005.art
FC=Validation/fcl/reco.fcl

this command
mu2e -c $FC -s $FN
runs without error to the end of the file (3000 events).

This command
mu2e -n 10 -c $FC -s $FN
gives the error below after one event. The file was made by mixing (a typical setup, but
I can't be sure). The product is found by artProductsSizes, but
the size is anomalously small. If you need full instructions to reproduce it,
let me know.

%MSG-s ArtException: PostEndJob 22-Mar-2018 13:49:25 CDT ModuleEndJob
cet::exception caught in art
---- OtherArt BEGIN
---- LogicError BEGIN
Principal::getForOutput
A product with a status of 'present' is not actually present.
The branch name is mu2e::SimParticlemv_g4run__beamg4s4conversion.
Contact a framework developer.
---- LogicError END
---- OtherArt END
%MSG


Related issues

Related to art - Bug #19809: seg fault caused by dropping sumdata::RunDataClosed2018-04-25

History

#1 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from New to Assigned
  • Assignee set to Kyle Knoepfel

#2 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from Assigned to Feedback

Can you provide a mu2e git commit with which we can reproduce this error?

#3 Updated by Raymond Culbertson over 1 year ago

source /cvmfs/mu2e.opensciencegrid.org/setupmu2e-art.sh
git clone ssh:///cvs/projects/mu2eofflinesoftwaremu2eoffline/Offline.git
cd Offline
git checkout f9b4b8acdb
source setup.sh
scons -j 20 &>b_00.log
  1. make the corrupt file
    mu2e -n 10 -c Validation/fcl/ceMixDigi.fcl -o mix.art -s \
    /pnfs/mu2e/tape/phy-sim/sim/mu2e/cd3-beam-g4s4-detconversion/v566/art/50/b6/sim.mu2e.cd3-beam-g4s4-detconversion.v566.004001_00000000.art
  2. demo error
    mu2e -s mix.art -n 5 -c Validation/fcl/reco.fcl

#4 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from Feedback to Assigned

The problem is, to some extent understood. Whenever the -n program is specified, if the number given is less than the total number of events in the input file, fast-cloning is deactivated. In that case, each product must be read from the input file, which triggered the above error. It is also clear that the product in question does not exist in the input file. Why it is being marked as present is not yet understood.

#5 Updated by Kyle Knoepfel over 1 year ago

  • Subject changed from using -n causes error to Branches created for dropped products
  • Target version set to 2.11.00
  • % Done changed from 0 to 90

The problem is understood. art's mechanisms for tracking dropped products is complicated, and because of this, it is easy for implementation errors to creep in. In this case, art 2.09 and later unintentionally created branches in the output file for some previously dropped products, creating an ambiguity for the framework.

A fix will be included for art 2.11.00--old files will not need to be regenerated.

Implemented with commit art:7275ed6.

#6 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from Assigned to Resolved

#7 Updated by Kyle Knoepfel over 1 year ago

  • % Done changed from 90 to 100

#8 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from Resolved to Closed

#9 Updated by Kyle Knoepfel over 1 year ago

  • Related to Bug #19809: seg fault caused by dropping sumdata::RunData added


Also available in: Atom PDF