Project

General

Profile

Feature #19426

Modules directory not processed by ssibuildshims

Added by Eric Flumerfelt over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
03/17/2018
Due date:
% Done:

100%

Estimated time:
Spent time:
Co-Assignees:
Duration:

Description

For the XDAQ product, I distribute a "FindUPSXdaq.cmake" file with similar functionality to "FindUPSRoot.cmake". However, with ssibuildshims v1_04_04, there is no support in make_source_code_distribution (or make_source_code_tarball) for a Modules subdirectory.

The easy solution would be to add Modules to the list of directories it processes, probably the more correct thing to do is make make_source_code_distribution more like make_distribution_tarball where you can specify what directories you want to be included.

History

#1 Updated by Lynn Garren over 1 year ago

  • Status changed from New to Feedback

By design, ssibuildshims expects the source code to be in a single tarball under the tar directory. Our bootstrap scripts use git archive to achieve this when appropriate. A source code tarball is not expected to mirror the structure of an eventual product distribution. Other directories are expected to be created by the build step and are handled by make_distribution_tarball.

We do not understand why you want to distribute extra directories with a source code tarball. Please explain.

#2 Updated by Lynn Garren over 1 year ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Closing this following a phone conversation with Eric and Ron.



Also available in: Atom PDF