Project

General

Profile

Feature #19422

Update of the software license

Added by Marco Mambelli over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
03/16/2018
Due date:
% Done:

0%

Estimated time:
Stakeholders:
Duration:

Description

Parag inquired w/ Fermilab about GlideinWMS license and they (Aaron Sauers <>) suggested an update

Copyright (c) <YEAR>, Fermi Research Alliance, LLC
All rights reserved.

Copyright (year of authorship). Fermi Research Alliance, LLC. This software was produced under U.S. Government contract DE-AC02-07CH11359 for Fermi National Accelerator Laboratory (Fermilab), which is operated by Fermi Research Alliance, LLC for the U.S. Department of Energy. The U.S. Government has rights to use, reproduce, and distribute this software.  NEITHER THE GOVERNMENT NOR FERMI RESEARCH ALLIANCE, LLC MAKES ANY WARRANTY, EXPRESS OR IMPLIED, OR ASSUMES ANY LIABILITY FOR THE USE OF THIS SOFTWARE.  If software is modified to produce derivative works, such modified software should be clearly marked, so as not to confuse it with the version available from Fermilab.

Additionally, redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
•       Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
•       Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
•       Neither the name of Fermi Research Alliance, LLC, Fermi National Accelerator Laboratory, Fermilab, the U.S. Government, nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY FERMI RESEARCH ALLIANCE, LLC AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL FERMI RESEARCH ALLIANCE, LLC OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

History

#1 Updated by Marco Mambelli over 1 year ago

  • Status changed from New to Feedback
  • Assignee set to Parag Mhashilkar

changes are in v3/19422

#2 Updated by Parag Mhashilkar over 1 year ago

  • Tracker changed from Bug to Feature
  • Assignee changed from Parag Mhashilkar to Marco Mambelli

Looks good. ready to erge

#3 Updated by Brian Bockelman over 1 year ago

This is a non-standard change to a BSD 3-clause license. Particularly, this part may be worrisome to collaborators as it is unclear how this interacts with the rest of the license:

If software is modified to produce derivative works, such modified software should be clearly marked, so as not to confuse it with the version available from Fermilab.

Could we ask Aaron whether this sentence could be dropped? Or, at least, why the license changed -- rather than just updating and clarifying the copyright holder?

#4 Updated by Parag Mhashilkar over 1 year ago

License changed because the previous version of the license was not as per the DOE requirements. Will ask Aaron, if we can drop this sentence.

#5 Updated by Marco Mambelli over 1 year ago

Suggested modification approved:

Yes, you can remove it.

From: Parag A Mhashilkar 
Sent: Friday, March 16, 2018 3:00 PM
To: Aaron Sauers <asauers@fnal.gov>
Cc: Marco Mambelli <marcom@fnal.gov>; Brian Paul Bockelman <bbockelm@cse.unl.edu>
Subject: Re: Fermilab software IP

Hi Aaron,

Some changes in this license raised concerns with our collaborators. Can we drop the following from the license?

As per Brian, This is a non-standard change to a BSD 3-clause license. Particularly, this part may be worrisome to collaborators as it is unclear how this interacts with the rest of the license:
If software is modified to produce derivative works, such modified software should be clearly marked, so as not to confuse it with the version available from Fermilab.

#6 Updated by Marco Mambelli over 1 year ago

  • Status changed from Feedback to Resolved

#7 Updated by Marco Mambelli over 1 year ago

  • Target version changed from v3_2_22 to v3_2_23

#8 Updated by Marco Mambelli about 1 year ago

  • Target version changed from v3_2_23 to v3_4_0

#9 Updated by Marco Mambelli about 1 year ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF