Project

General

Profile

Bug #19353

art does not perform config dumping correctly when using a URI as input file

Added by Gianluca Petrillo over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Application
Target version:
Start date:
03/12/2018
Due date:
% Done:

100%

Estimated time:
4.00 h
Spent time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

Running:

touch empty.fcl
lar -c empty.fcl -s root://fndca1.fnal.gov:1094/pnfs/fnal.gov/usr/sbnd/persistent/ContinuousIntegration/reference/standard/gen/nucosmics_gen_test_sbndcode_Reference-201803090902.root --config-out empty.cfg
produces an empty empty.cfg file. Running
lar -c empty.fcl -s root://fndca1.fnal.gov:1094/pnfs/fnalgov/usr/sbnd/persistent/ContinuousIntegration/reference/standard/gen/nucosmics_gen_test_sbndcode_Reference-201803090902.root --config-out empty.cfg
instead (the fnal.gov in the path became fnalgov), the configuration dump is non-empty, as it should (but of course the input file is not found).

History

#1 Updated by Kyle Knoepfel over 2 years ago

  • Status changed from New to Feedback

Can you attach the post-processed output files?

#2 Updated by Kyle Knoepfel over 2 years ago

  • Status changed from Feedback to Assigned
  • Assignee set to Kyle Knoepfel
  • Estimated time set to 4.00 h

This bug has been confirmed. A quick fix is possible, but we'd prefer to enact a more robust solution. Is a bug-fix release of art requested at this time?

#3 Updated by Gianluca Petrillo over 2 years ago

I would like to have it fixed before art version 3, if that's the question.
I can wait until the next scheduled art 2.10.x release, if any.

#4 Updated by Kyle Knoepfel over 2 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

The bug was due to accessing a moved-from address. The program-options interactions with the main executable have been improved. Since the configuration persisted to disk has been adjusted, this corresponds to a breaking change and will thus need to go in the next minor version of art. If you would like an art 2.11 series with this fix, please open a feature request.

Implemented with commits:

#5 Updated by Kyle Knoepfel over 2 years ago

  • Target version set to 2.11.00

#6 Updated by Kyle Knoepfel over 2 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF