Project

General

Profile

Bug #1921

Event mixing with a list of input files.

Added by Rob Kutschke over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Category:
Navigation
Target version:
Start date:
09/26/2011
Due date:
% Done:

100%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

I was running an event mixing test with two input files, the first containing 505 events and the second containing 513 events. My test job mixes in exactly 10 events from the mixing file per primary event. I asked for 60 primary events. The first 50 primary events take the first 500 events from the first file ( events 0 through 499). The 51st primary event contains events 500 through 509 from the secondary file. The mixing template throws on the 52nd event because it reaches the end of the second file.

Associated revisions

Revision 2ab9510a (diff)
Added by Christopher Green over 8 years ago

Add test for issue #1921.

Revision 34125e2b (diff)
Added by Christopher Green over 8 years ago

Fixes for issue #1921.

MixHelper: nEventsRead_ must be reset upon file change.

RootBranchInfoList: reset() method did not clear data_; more safety.

Revision 99d54017 (diff)
Added by Christopher Green over 8 years ago

Add test for issue #1921.

Revision 1827bd9b (diff)
Added by Christopher Green over 8 years ago

Fixes for issue #1921.

MixHelper: nEventsRead_ must be reset upon file change.

RootBranchInfoList: reset() method did not clear data_; more safety.

History

#1 Updated by Christopher Green over 8 years ago

  • Category set to Navigation
  • Status changed from New to Assigned
  • Assignee set to Christopher Green
  • Target version set to 0.07.16

This bug has been reproduced with an ART test case; study and fix is underway.

#2 Updated by Christopher Green over 8 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Two issues were identified resulting in incorrect behavior with multiple input files: these have been fixed with 34125e2.

#3 Updated by Christopher Green over 8 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF