Project

General

Profile

Bug #19121

Problem with running trajcluster on DUNE events

Added by Tingjun Yang over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Start date:
02/25/2018
Due date:
% Done:

100%

Estimated time:
Duration:

Description

In larsoft/dunetpc v06_69_00, the following command gives an error:
lar -c standard_reco_dune10kt_nu_1x2x6.fcl --nskip 12 -n 1 /pnfs/dune/scratch/users/vito/CI_grid_input_test//CI_build_lar_ci_1750/sim/prodgenie_nue_dune10kt_1x2x6_detsim_01.root

It is possible the shower reconstruction is not configured correctly in the DUNE configuration file.

History

#1 Updated by Bruce Baller over 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

This was caused by a shower having an invalid index to a PFParticle. I added protection for this in TrajCluster_module. I also fixed the logic for defining TrajCluster debug mode. DUNE jobs were always being run in debug mode.



Also available in: Atom PDF