Project

General

Profile

Bug #18999

Unable to build lariatsoft/larsoft v06_68_00 using cetbuildtools v7_00_02

Added by Johnny Ho over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
02/14/2018
Due date:
% Done:

100%

Estimated time:
Duration:

Description

Hello!

I'm trying to build and tag the next lariatsoft release with larsoft v06_68_00 and cetbuildtools v7_00_02, and I am getting the following error when running mrb i --generator ninja

/lariat/app/users/johnnyho/work/release/lariatsoft/develop/build_slf6.x86_64
calling buildtool -I /lariat/app/users/johnnyho/work/release/lariatsoft/develop/localProducts_lariatsoft_develop_e15_prof -i --generator ninja
INFO: Install prefix = /lariat/app/users/johnnyho/work/release/lariatsoft/develop/localProducts_lariatsoft_develop_e15_prof
INFO: CETPKG_TYPE = Prof

------------------------------------
INFO: Stage cmake.
------------------------------------

-- The C compiler identification is GNU 6.4.0
-- The CXX compiler identification is GNU 6.4.0
-- Check for working C compiler: /grid/fermiapp/larsoft/products/gcc/v6_4_0/Linux64bit+2.6-2.12/bin/gcc
-- Check for working C compiler: /grid/fermiapp/larsoft/products/gcc/v6_4_0/Linux64bit+2.6-2.12/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /grid/fermiapp/larsoft/products/gcc/v6_4_0/Linux64bit+2.6-2.12/bin/g++
-- Check for working CXX compiler: /grid/fermiapp/larsoft/products/gcc/v6_4_0/Linux64bit+2.6-2.12/bin/g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- cetbuildtools_BINDIR = /grid/fermiapp/larsoft/products/cetbuildtools/v7_00_02/bin
-- full qual e15:prof reduced to e15
-- Product is lariatsoft v06_68_00 e15:prof
-- Module path is /grid/fermiapp/larsoft/products/canvas_root_io/v1_00_05/Modules;/grid/fermiapp/larsoft/products/cetbuildtools/v7_00_02/Modules
-- set_install_root: PACKAGE_TOP_DIRECTORY is /lariat/app/users/johnnyho/work/release/lariatsoft/develop/srcs/lariatsoft
CMake Error at /grid/fermiapp/larsoft/products/cetbuildtools/v7_00_02/Modules/CetCMakeEnv.cmake:57 (message):
  CMAKE_C_COMPILER set to
  /grid/fermiapp/larsoft/products/gcc/v6_4_0/Linux64bit+2.6-2.12/bin/gcc:
  expected match to
  "^/grid/fermiapp/products/larsoft/gcc/v6_4_0/Linux64bit\+2\.6-2\.12/bin/gcc\$".

  Use buildtool or preface cmake invocation with "env CC=." Use buildtool -c
  if changing qualifier.
Call Stack (most recent call first):
  /grid/fermiapp/larsoft/products/cetbuildtools/v7_00_02/Modules/CetCMakeEnv.cmake:130 (_verify_cc)
  /grid/fermiapp/larsoft/products/cetbuildtools/v7_00_02/Modules/CetCMakeEnv.cmake:141 (_study_compiler)
  /grid/fermiapp/larsoft/products/cetbuildtools/v7_00_02/Modules/CetCMakeEnv.cmake:246 (_verify_compiler_quals)
  lariatsoft/CMakeLists.txt:32 (cet_cmake_env)

-- Configuring incomplete, errors occurred!
See also "/lariat/app/users/johnnyho/work/release/lariatsoft/develop/build_slf6.x86_64/CMakeFiles/CMakeOutput.log".

------------------------------------
ERROR: Stage cmake failed.
------------------------------------

It looks to me like CMAKE_C_COMPILER is expected to have escape characters?

I have tried rolling back to cetbuildtools v6_01_01 and it builds successfully. Any suggestions on how to proceed or what the cause of this might be?

Thanks!

Johnny

History

#1 Updated by Lynn Garren over 1 year ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

This problem is already fixed in cetbuildtools v7_00_03, which is now installed in /grid/fermiapp/products/larsoft.

#2 Updated by Lynn Garren over 1 year ago

  • Status changed from Resolved to Closed

We recommend using the newly available cetbuildtools v7_02_01.



Also available in: Atom PDF