Project

General

Profile

Bug #18944

Root file closes on shutdown transition rather than stop transition

Added by John Freeman over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Known Issues
Target version:
Start date:
02/09/2018
Due date:
% Done:

0%

Estimated time:
Experiment:
Co-Assignees:
Duration:

Description

Using artdaq-demo v3_00_02 / artdaq v3_00_02 on woof (installed using the instructions at the top of the artdaq-demo wiki with --tag=v3_00_02), it appears that the DataLogger, rather than closing the *.root file after the stop transition, instead closes it on the shutdown transition. I've observed this behavior both by running the classic start2x2x2System.sh / manage2x2x2System.sh scripts, as well as startAsciiSimulatorExample.sh / manageAsciiSimulatorExample.sh.

History

#1 Updated by Eric Flumerfelt over 2 years ago

I believe this is a feature, not a bug.

RootOutput has the fileProperties block, in which you may (for some reason) specify that you want MORE than one run per output file. In that case, if you did a stop then a start to increment the run number, the new run would continue to be written into the same file.

With the default of one run per file, if you do a stop then a start, the file should be closed and a new one opened.

This isn't really a problem as long as the stop and shutdown transitions are both reliable and done in the correct order through the system...

#2 Updated by John Freeman over 2 years ago

Two things that will probably require more attention given this change:

-How to deal with a situation where the DataLogger stops just fine, but other artdaq processes don't (e.g., a poorly written fragment generator just hangs)
-Making sure that people don't just stop the system, and then neglect to send a shutdown. A warning message may suffice.

#3 Updated by Eric Flumerfelt over 2 years ago

  • Project changed from artdaq Demo to artdaq
  • Category set to Known Issues
  • Status changed from New to Closed
  • Assignee set to Eric Flumerfelt
  • Target version set to artdaq v3_00_03


Also available in: Atom PDF