Project

General

Profile

Bug #18773

Single turn plot not showing current data until you toggle single turn -> charge plot -> single turn

Added by Denton Morris over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Start date:
01/22/2018
Due date:
% Done:

100%

Estimated time:
Spent time:
Duration:

Description

Taking new data with the plot option of Single Turn shows old data until you toggle from Single Turn to Charge Plot and back to Single Turn.

2018-01-22.10.17.08.790.png (9.77 KB) 2018-01-22.10.17.08.790.png Spec used Denton Morris, 01/22/2018 10:21 AM
2018-01-22.10.17.11.245.png (8.84 KB) 2018-01-22.10.17.11.245.png Original plot config Denton Morris, 01/22/2018 10:21 AM
2018-01-22.10.17.14.077.png (77.6 KB) 2018-01-22.10.17.14.077.png Plot showing old single turn data Denton Morris, 01/22/2018 10:21 AM
2018-01-22.10.17.19.349.png (8.84 KB) 2018-01-22.10.17.19.349.png Toggled to Charge Plot, then back to Single Turn Denton Morris, 01/22/2018 10:21 AM
2018-01-22.10.17.39.708.png (77.5 KB) 2018-01-22.10.17.39.708.png Now getting current data Denton Morris, 01/22/2018 10:21 AM

History

#1 Updated by Elliott McCrory over 1 year ago

Please try to reproduce the problem on the modified code on the Z page.

#2 Updated by Denton Morris over 1 year ago

Same behavior on the Z page.

#3 Updated by Elliott McCrory over 1 year ago

  • Assignee changed from Elliott McCrory to David Slimmer

Dave - I am not able to see how my console code could make this mistake. Can you have a look, please, at the front end? Is it possible that you are not sending the right data?

The sequence of data requests Denton specifies here will reproduce this bug on the ACNET console program. Another way to reset the data is to ask for a slightly different turn number (e.g., ask for 51, and then ask for 50 - it will report the correct turn #50 this time).

Thanks - Elliott.

#4 Updated by David Slimmer over 1 year ago

  • Status changed from New to Work in progress

Elliott - I will need you to demonstrate the problem. I can't seem to get it display a single turn profile that does not track the one displayed on the front end.

There seems to be a hard limit on the number of files (314) displayed by "Select & Plot File".
There are currently 364 saved data files (names) on R4HIPM, and they should fit in the device R:4HLOGS. Can you modify the console code to read either to the maximum number of characters for R:4HLOGS (32760) OR until you read no more file names?

#5 Updated by David Slimmer over 1 year ago

  • Status changed from Work in progress to Resolved
  • % Done changed from 0 to 100

Modified front end code so the Fit Turn is taken from R:4HPMTF instead of the spec when data is acquired from an Acnet console. Also requires modified handling of R:4HMTF in I33.

#6 Updated by Denton Morris over 1 year ago

David Slimmer wrote:

Modified front end code so the Fit Turn is taken from R:4HPMTF instead of the spec when data is acquired from an Acnet console. Also requires modified handling of R:4HMTF in I33.

Has this been propagated to the other IPMs? I still see this behavior on Recycler V103 IPM but haven't looked at MI IPMs yet.



Also available in: Atom PDF