Project

General

Profile

Bug #18733

mixed file has events but can't read them

Added by Raymond Culbertson over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
I/O
Target version:
Start date:
01/12/2018
Due date:
% Done:

100%

Estimated time:
Spent time:
Occurs In:
Scope:
Internal
Experiment:
Mu2e
SSI Package:
art
Duration:

Description

A file
FN=/pnfs/mu2e/scratch/users/rlc/dig.owner.val-ceMixDigi.dsconf.seq.art
produced by a mixing job has events:

> count_events $FN
/pnfs/mu2e/scratch/users/rlc/dig.owner.val-ceMixDigi.dsconf.seq.art     1      1    10      0
and products:
 > artProductSizes $FN
Number of entries:  10
        Size     Size/Entry   Fraction  Data Product Name
     (bytes)       (bytes)

      805199        80519.9      0.408  mu2e::StrawDigis_makeSD__ceMixDigi.
      359470        35947.0      0.182  mu2e::StepPointMCs_detectorFilter_calori
...

But when I run a job with a simple, stable module:

> mu2e --trace -c Print/fcl/dumpDataProducts.fcl -s $FN

it finds no events:

++ Job started
++++open input file
++++finished: open input file /pnfs/mu2e/scratch/users/rlc/dig.owner.val-ceMixDigi.dsconf.seq.art
++++close output file from dump
++++finished close output file <none> from dump
++++close input file
...
Art has completed and will exit with status 0.

I can produce and read non-mixed files in this build.

To reproduce
source /cvmfs/mu2e.opensciencegrid.org/setupmu2e-art.sh
git clone http://cdcvs.fnal.gov/projects/mu2eofflinesoftwaremu2eoffline/Offline.git
cd Offline
git checkout -b temp 72f3b6b32814
source setup.sh
scons -j 20 >& build.log
mu2e --trace -c Print/fcl/dumpDataProducts.fcl -s $FN


Related issues

Related to art - Bug #18726: Mu2e GenEventCount not foundClosed01/11/2018

History

#1 Updated by Kyle Knoepfel over 2 years ago

The file looks malformed. Was it produced with version 2.09.04?

#2 Updated by Kyle Knoepfel over 2 years ago

  • Status changed from New to Feedback

#3 Updated by Raymond Culbertson over 2 years ago

Yes, the file is mixed in v2_09_04, from two much older files.
There was no reported error in producing the file.
The same mixing job worked in v2_07_03.

To reproduce the mixing:
scp ${USER}@mu2egpvm01:/mu2e/app/users/rlc/dev/Offline/Validation/fcl/ceMixDigi.fcl Validation/fcl
scp ${USER}@mu2egpvm01:/mu2e/app/users/rlc/dev/Offline/Validation/fcl/prolog.fcl Validation/fcl
mu2e -c Validation/fcl/ceMixDigi.fcl -s /pnfs/mu2e/tape/phy-sim/sim/mu2e/cd3-beam-g4s4-detconversion/v566/1d/ab/sim.mu2e.cd3-beam-g4s4-detconversion.v566.004001_00006825.art -n 10

#4 Updated by Kyle Knoepfel over 2 years ago

Okay, thanks for the instructions to reproduce the file. Andrei stopped by yesterday with a problem that looks similar--his problem was fixed with art 2.09.06 (tagged this morning). I'd like to see if this error is fixed also with art 2.09.06.

#5 Updated by Kyle Knoepfel over 2 years ago

  • Category set to I/O
  • Status changed from Feedback to Assigned
  • Assignee set to Kyle Knoepfel
  • SSI Package art added

#6 Updated by Kyle Knoepfel over 2 years ago

  • Status changed from Assigned to Resolved
  • Target version set to 2.09.06
  • % Done changed from 0 to 100

It turns out the error encountered is a symptom of the same error that was exposed by issue #18726. I am able to produce the malformed file in art 2.09.04, and I verify that updating to art 2.09.06 will allow mixed-event files to be correctly formed, thus resolving this bug.

Our apologies for the inconvenience.

#7 Updated by Kyle Knoepfel over 2 years ago

  • Description updated (diff)

#8 Updated by Kyle Knoepfel over 2 years ago

  • Related to Bug #18726: Mu2e GenEventCount not found added

#9 Updated by Kyle Knoepfel over 2 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF