Project

General

Profile

Bug #18384

Seg fault copying zero-event artroot file.

Added by Herbert Greenlee over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
11/27/2017
Due date:
% Done:

100%

Estimated time:
Spent time:
Occurs In:
Scope:
Internal
Experiment:
MicroBooNE
SSI Package:
art
Duration:

Description

I get a seg fault from inside art when copying an artroot file with zero events.

$ lar -c copy.fcl -s /uboone/data/users/uboonepro/crash_zero.root
27-Nov-2017 17:06:36 CST Opened input file "/uboone/data/users/uboonepro/crash_zero.root"
%MSG-i FastCloning: RootOutput:out1@Construction 27-Nov-2017 17:06:36 CST ModuleConstruction
Initial fast cloning configuration (from default): true
%MSG
27-Nov-2017 17:06:36 CST Opened output file with pattern "merged.root"
%MSG-w FastCloning: PostBeginSubRun 27-Nov-2017 17:06:36 CST run: 6551 subRun: 212
Fast cloning deactivated for this input file due to information in FileBlock.
%MSG
Segmentation fault

The zero-event file was created with art v2.05.00. Crash happens with art v2_05.00 as well as art v2_08_04.

Crash happens in RootOutputFile.cc.

#0 0x00007ffff5433e2f in (anonymous namespace)::maybeInvalidateRangeSet (bt=art::InSubRun, principalRS=..., productRS=...) at /scratch/workspace/nu-release-build/v2_06_02/s43-e10/prof/build/art/v2_05_00/src/art/Framework/IO/Root/RootOutputFile.cc:227

The input file is not obviously corrupted, and was successfully written by art from an input file with a nonzero number of events.

History

#1 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from New to Accepted

#2 Updated by Kyle Knoepfel over 1 year ago

  • Category set to Infrastructure
  • Status changed from Accepted to Assigned
  • Assignee set to Kyle Knoepfel

Herb, the problem is understood, and the solution is straightforward. Is it sufficient to issue a bug-fix release for art 2.09? Or is a 2.08 bug-fix release required?

#3 Updated by Herbert Greenlee over 1 year ago

I'd prefer a patch for e10 (v2_05_xx) and development head (v2_09 is acceptable).

#4 Updated by Kyle Knoepfel over 1 year ago

We prefer not to backport all the way to art v2_05 since that leaves a lot of versions in between without the fix. Is there a reason why art v2_08 would not be sufficient?

#5 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from Assigned to Resolved
  • Target version set to 2.05.01
  • % Done changed from 0 to 100
  • Occurs In 2.05.00 added
  • Occurs In deleted (2.08.04)
  • SSI Package art added

Based on discussions with Herb, we will provide an art 2.05 bug-fix release with the understanding that art series 2.06, 2.07, and 2.08 will not automatically include the fix. A bug-fix release from any of those series can be requested if necessary.

Fix implemented with commits canvas:fd47f45 and art:1440031.

#6 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF