Project

General

Profile

Bug #18263

Could not display trajcluster in event display

Added by Tingjun Yang almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Start date:
11/14/2017
Due date:
% Done:

100%

Estimated time:
Duration:

Description

I could not display trajcluster in event display using v06_56_00.
v06_55_01 is working on the same reco file. I am investigating.

lar -c evd_lariat.fcl /pnfs/lariat/scratch/users/vito/ci_output/lariatsoft_CIbuild_92/ci_reco2D_RUN2_regression_test_lariatsoft/lariat_r009535_sr0400_reco2D_Current.root

History

#1 Updated by Tingjun Yang almost 2 years ago

  • Subject changed from Could you display trajcluster in event display to Could not display trajcluster in event display
  • Status changed from New to Assigned

#2 Updated by Tingjun Yang almost 2 years ago

  • % Done changed from 0 to 50

Bruce and I both found the cause:
I grabbed lareventdisplay and used the debugger to find that clusters aren’t drawn if there are no space points.

// We want to draw the hits that are associated to "free" space points (non clustered)
// This is done here, before drawing the hits on clusters so they will be "under" the cluster
// hits (since spacepoints could be made from a used 2D hit but then not used themselves)
// Get the space points created by the PFParticle producer
std::vector<art::Ptr<recob::SpacePoint>> spacePointVec;
this->GetSpacePoints(evt, which, spacePointVec);
// No space points no continue
if (spacePointVec.size() < 1) continue;

Tracy is notified and fixing the problem.

#3 Updated by Tingjun Yang almost 2 years ago

  • % Done changed from 50 to 100

#4 Updated by Tingjun Yang almost 2 years ago

  • Status changed from Assigned to Resolved


Also available in: Atom PDF