Project

General

Profile

Feature #18159

Another request for FileDumperOutput ...

Added by Rob Kutschke almost 2 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
11/08/2017
Due date:
% Done:

0%

Estimated time:
2.00 h
Scope:
Internal
Experiment:
Mu2e
SSI Package:
art
Duration:

Description

I would like an option in FileDumperOutput to print the product id as well as the other information. It can be off by default. I see this as an option within the parameter set of the module.

The reason I ask is that people need to understand art::ProductIDs if they are making Ptr and Assns objects. In the old days they also needed to understand them in order to understand which files with different processing histories could be read in a single job - are there still restrictions on consistent processing histories that are most easily understood if you know about art::ProductID?

An easy way to introduce them to run FileDumperOutput on a standard file (such as the toyExperiment example input files); if it prints the ProductIDs then a simple story serves as the introduction.


Related issues

Is duplicate of art - Feature #18153: Have FileDumperOutput print the ID of event being printedClosed2017-11-08

History

#1 Updated by Kyle Knoepfel almost 2 years ago

  • Status changed from New to Accepted

This is simple to implement; however, two issues arise:

  • The table width is already large for the current FileDumperOutput printout. For that reason, we will not enable this by default.
  • There is an art-provided DataFlowDumper module, which produces a dot file with all of the data-product dependencies. This could be a preferable alternative.

#2 Updated by Kyle Knoepfel over 1 year ago

  • Target version set to Vega

#3 Updated by Kyle Knoepfel about 1 year ago

  • Estimated time set to 2.00 h
  • SSI Package art added

#4 Updated by Kyle Knoepfel 12 months ago

  • Is duplicate of Feature #18153: Have FileDumperOutput print the ID of event being printed added

#5 Updated by Kyle Knoepfel 12 months ago

  • Status changed from Accepted to Closed
  • Target version deleted (Vega)


Also available in: Atom PDF