Project

General

Profile

Feature #17970

Support mechanism for VO & possibly site to specify list of potential bind mountpoints for singularity

Added by Dave Dykstra almost 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
10/19/2017
Due date:
% Done:

0%

Estimated time:
Stakeholders:
Duration:

Description

I learned that CMS is looking for a list of directories, and if any of the directories exist they are bind-mounted in to the singularity session. In particular, the list is "/lfs_roots /cms /hadoop /hdfs /mnt/hadoop /etc/cvmfs/SITECONF". It doesn't make sense to have GlideinWMS hardcode these, but there should be a mechanism (e.g. an environment variable) that the VO pilot can use to pass in a list of potential directories, if it doesn't already exist.

Possibly there could be a separate mechanism for site administrators to add directories, or we could leave it up to the VO to look for an additional variable and add it to their list.


Related issues

Related to GlideinWMS - Milestone #19515: Roadmap for Singularity supportNew03/27/2018

History

#1 Updated by Dave Dykstra almost 3 years ago

It just occurred to me that VOs will have to supply bind mount points in the image anyway, for sure for unprivileged singularity, so there's probably not a lot of value to accept additional mountpoints from the site administrator. There does still need to be a way for the VO to pass them to glideinWMS.

#2 Updated by Dave Dykstra about 2 years ago

singularity-2.6.0 will include the underlay feature so bind mountpoints will be able to added to an image. I discovered a couple of months ago that sites can set $SINGULARITY_BINDPATH which already works for extra bind mountpoints. Marco & I discussed having a separate GlideinWMS for VOs to do it but I don't know if he decided to it or not. We could also just tell VOs to add to $SINGULARITY_BINDPATH.

#3 Updated by Marco Mambelli about 2 years ago

  • Assignee set to Marco Mambelli
  • Target version set to v3_4_1

This is being covered in [#20030]

#4 Updated by Marco Mambelli almost 2 years ago

  • Status changed from New to Closed

Duplicate of [#20030]

#5 Updated by Marco Mambelli almost 2 years ago



Also available in: Atom PDF