Project

General

Profile

Support #17752

art 2.8.3 generating a bus error under GDB (SLF6)

Added by Gianluca Petrillo over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Third Party
Target version:
-
Start date:
09/20/2017
Due date:
% Done:

0%

Estimated time:
Scope:
Internal
Experiment:
-
SSI Package:
art
Duration:

Description

The following set of commands to debug art:

source /cvmfs/fermilab.opensciencegrid.org/products/larsoft/setup
setup art v2_08_03 -q debug:e14:nu
setup gdb v7_12
gdb art

and then issuing the command run causes a "bus error" with the following output:
GNU gdb (GDB) 7.12
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying" 
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from art...done.
(gdb) run
Starting program: /cvmfs/fermilab.opensciencegrid.org/products/larsoft/art/v2_08_03/slf6.x86_64.e14.nu.debug/bin/art 
Bus error

I have tried this on uboonegpvm06.fnal.gov, sbndgpvm02.fnal.gov (both SLF6), with the same effect, and woof.fnal.gov (SLF7?), where it worked fine.


Related issues

Is duplicate of art - Support #17751: a problem with debugging art v2_07-based executables with gdbClosed2017-09-20

History

#1 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from New to Rejected

Rejected because this duplicates issue #17751.

#2 Updated by Kyle Knoepfel over 1 year ago

  • Is duplicate of Support #17751: a problem with debugging art v2_07-based executables with gdb added

#3 Updated by Gianluca Petrillo over 1 year ago

I confirm that using gdb v8_0_1 as distributed now for SLF6 solves the issue.

#4 Updated by Kyle Knoepfel over 1 year ago

  • Status changed from Rejected to Closed


Also available in: Atom PDF