Project

General

Profile

Bug #17556

Missing module label in exception message

Added by Rob Kutschke about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
08/21/2017
Due date:
% Done:

100%

Estimated time:
Spent time:
Occurs In:
Scope:
Internal
Experiment:
Mu2e
SSI Package:
art
Duration:

Description

One of my Mu2e colleagues, Dave Brown ( ), reports a problem in the information produced when an art module throws an exception - see below. The exception message does not contain the module label that was active when the exception occurred.

We are using art v2_06_02 and plan to upgrade in the next day or so to v2_07_03. We will not upgrade to art v2_08_02 for a while because our prototype online system is not yet ready for that.


Hi all,

I'm trying to debug some new configuration with the head of Offline,
and unfortunately I find the 'module' information is missing from the
art exception printout as shown below (no module is listed after
'cet::exception going through module'). This makes it hard to debug.

Has anyone else noticed this?
thanks, Dave

cet::exception caught in art
---- EventProcessorFailure BEGIN
 An exception occurred during current event processing
 ---- EventProcessorFailure BEGIN
   An exception occurred during current event processing
   ---- ScheduleExecutionFailure BEGIN
     ProcessingStopped.
     ---- ProductNotFound BEGIN
       getByLabel: Found zero products matching all criteria
       Looking for type: std::vector<mu2e::MVAStruct<mu2e::TrkQualDetail> >
       Looking for module label: KFFDeM
       Looking for productInstanceName:

       cet::exception going through module
     ---- ProductNotFound END
     Exception going through path end_path
   ---- ScheduleExecutionFailure END
 ---- EventProcessorFailure END
---- EventProcessorFailure END
%MSG
Art has completed and will exit with status 18.

History

#1 Updated by Kyle Knoepfel about 2 years ago

  • Description updated (diff)

#2 Updated by Kyle Knoepfel about 2 years ago

  • Is duplicate of Feature #17087: Hermetic error message on mismatching product ID and data type added

#3 Updated by Kyle Knoepfel about 2 years ago

  • Status changed from New to Assigned
  • Assignee set to Kyle Knoepfel

#4 Updated by Kyle Knoepfel about 2 years ago

  • Description updated (diff)
  • Category set to Infrastructure
  • Target version set to 2.09.00
  • % Done changed from 0 to 90

Turns out that this was a simple fix. One more test to verify, and then I will mark as resolved.

#5 Updated by Kyle Knoepfel about 2 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 90 to 100
  • SSI Package art added

Resolved with commits art:03c411 and art:f7d417.

#6 Updated by Kyle Knoepfel about 2 years ago

  • Is duplicate of deleted (Feature #17087: Hermetic error message on mismatching product ID and data type)

#7 Updated by Kyle Knoepfel about 2 years ago

  • Target version changed from 2.09.00 to 2.08.03

#8 Updated by Kyle Knoepfel about 2 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF