Project

General

Profile

Support #17552

Cannot preserve changes to event display services

Added by Tingjun Yang about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Application
Target version:
-
Start date:
08/21/2017
Due date:
% Done:

100%

Estimated time:
Spent time:
Scope:
Experiment:
-
SSI Package:
Duration:

Description

Dear LArSoft experts,

I noticed a quite annoying feature of the event display in the latest releases. If I want to change the TrackModuleLabel I can do so by opening RecoDrawingOptions and change the value for TrackModuleLable and confirm the change by hitting enter and clicking 'OK'. But the next time I open RecoDrawingOptions, the value for TrackModuleLabel will go back to the default value set by the fcl file, not the one I just changed. Note RecoDrawingOptions is implemented as a reconfigurable service in the event display code.

I suspect this may be related to issue #16803. I can take a closer look, but if the experts (especially Kyle) have comments, that would be great.

Thanks,
Tingjun

History

#1 Updated by Kyle Knoepfel about 2 years ago

Tingjun, it looks like this was an oversight whenever I implemented the Reconfigurable service interface for nutools. I have pushed a fix to nutools on feature branch feature/knoepfel_evdPSet. I will now work on ensuring that the committed fix does indeed resolve the issue.

Can someone with the correct permissions please re-assign this issue to the art issue tracker as a support request?

#2 Updated by Lynn Garren about 2 years ago

  • Project changed from LArSoft to art

#3 Updated by Kyle Knoepfel about 2 years ago

  • Category set to Application
  • Status changed from New to Resolved
  • Assignee set to Kyle Knoepfel
  • % Done changed from 0 to 100

I confirm that the above change fixes the problem.

#4 Updated by Tingjun Yang about 2 years ago

Thanks Kyle for fixing the problem.

Lynn, is there still time to build a nutools for this week's release?

#5 Updated by Lynn Garren about 2 years ago

build of nutools v2_15_01 in progress.

#6 Updated by Tingjun Yang about 2 years ago

Thanks Lynn.
Lynn Garren wrote:

build of nutools v2_15_01 in progress.

#7 Updated by Tingjun Yang about 2 years ago

I confirm the problem is resolved in larsoft v06_47_01.

Thanks Kyle for the quick fix and thanks Lynn for promptly including it in the new release!

#8 Updated by Kyle Knoepfel about 2 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF