Project

General

Profile

Bug #1741

Elevated privileges needed to create new Detectors

Added by Tim Rupp about 8 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Start date:
08/25/2011
Due date:
% Done:

0%

Estimated time:
Duration:

Description

It appears one needs elevated privileges to create new detectors in TIssue.

I'm not quite following the logic on this one. The detectors themselves are just configurations in a database. I would have accepted that you could configure a blocking detector without the TIssue dev's knowledge, but you can do that right now by just modifying an existing detector, so I reject that argument.

Other than that, it seems to me that detectors are harmless. Correct, there cannot be duplicates, but afaik this is already handled. If that's the case, then it shouldn't be necessary to burden the creation of new Detectors on the TIssue developers; it should be something that the people using the system can administer.

History

#1 Updated by Lauri Carpenter about 8 years ago

The TIssue administrators aka the tissue developers are the only people who can create NEW detectors. This is so that we (the people on the line in case things break) are aware of all detectors that are using our system. Once a detector is created, and an administrator has been designated for that detector, the named administrator can set their detector configuration any way that they like.

This is not a bug, it is a feature.

Case closed.

#2 Updated by Lauri Carpenter about 8 years ago

  • Status changed from New to Rejected


Also available in: Atom PDF