Project

General

Profile

Bug #17280

PMA crashes on argoneut event

Added by Tingjun Yang about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
07/26/2017
Due date:
% Done:

100%

Estimated time:
Occurs In:
Experiment:
ArgoNeut
Co-Assignees:
Duration:

Description

Starting from v06_45_00, PMA causes the following exception on argoneut events:

cet::exception caught in art                                                                  
---- OtherArt BEGIN
  ---- EventProcessorFailure BEGIN
    EventProcessor: an exception occurred during current event processing
    ---- ScheduleExecutionFailure BEGIN
      Path: ProcessingStopped.
      ---- PlaneOutOfRange BEGIN
        Request for non-existant plane 2
        cet::exception going through module
      ---- PlaneOutOfRange END
      Exception going through path reco
    ---- ScheduleExecutionFailure END
  ---- EventProcessorFailure END

Allinea shows the problem is in PmaNode3D.cxx:
void pma::Node3D::UpdateProj2D(void)
{
    for (size_t i = 0; i < 3; ++i)  // *** change to MaxPlanes ***
    {
        fProj2D[i].Set(fTpcGeo.Plane(i).PlaneCoordinate(fPoint3D), fPoint3D.X() - fDriftOffset);
    }
}

ArgoNeuT only has two planes.

Thanks,
Tingjun

History

#1 Updated by Tingjun Yang about 2 years ago

To reproduce this problem:

lar -c standard_reco_mc_t962.fcl /pnfs/argoneut/persistent/users/tjyang/v06_17_00_02/sim/genie/17647734_2301/genie_anu_17647734_23010_caa69374-7b6f-4d30-8f1e-f71f799a8e7f.root --no-output -n 1

#2 Updated by Robert Sulej about 2 years ago

Fixing... I don't know why I did this.
Thanks,
Robert

#3 Updated by Lynn Garren about 2 years ago

  • Status changed from New to Feedback

Is this now resolved in the head of develop?

#4 Updated by Robert Sulej about 2 years ago

Yes, it is fixed in develop. I let Tingjun to confirm and close.

#5 Updated by Tingjun Yang about 2 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

#6 Updated by Tingjun Yang about 2 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF