Project

General

Profile

Bug #17206

Segfault when running standard_ana_dune10kt.fcl

Added by Steven Gardiner about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Start date:
07/18/2017
Due date:
% Done:

100%

Estimated time:
Duration:

Description

Running the standard analysis script on a LArSoft ROOT file containing MARLEY events results in a segmentation fault. Doing the same for GENIE events works fine.

Associated revisions

Revision 9ffb10e1 (diff)
Added by Steven Gardiner about 3 years ago

Use associations with simb::MCTruth objects to access the simb::MCFlux
objects in the AnalysisTree module instead of assuming that they will
always be present. This commit resolves dunetpc issue #17206.

History

#1 Updated by Steven Gardiner about 3 years ago

The issue appears to be caused by the AnalysisTree module. The current version of the module assumes that every simb::MCTruth object produced by the generator with label fGenieGenModuleLabel will also have a corresponding simb::MCFlux object. No explicit check of this, however, is made before the simb::MCFlux data members are accessed starting on line 4690. If a generator that does not produce simb::MCFlux objects (e.g., MARLEY) is referred to by fGenieGenModuleLabel, then the module will fail to notice the absence of the simb::MCFlux objects, resulting in a segfault when the module tries to use them.

#2 Updated by Steven Gardiner about 3 years ago

  • Status changed from New to Resolved

#3 Updated by Tingjun Yang almost 3 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100


Also available in: Atom PDF