Project

General

Profile

Bug #16603

test server on SL7

Added by Dennis Box over 2 years ago. Updated 11 months ago.

Status:
Work in progress
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
05/19/2017
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

History

#1 Updated by Dennis Box over 1 year ago

  • Target version set to v1.2.8
Findings so far:
  • default cherrypy versions are different on SL6 and SL7, minor modifcations needed
  • SELinux needs to be disabled for jobsub server to authenticate

#2 Updated by Dennis Box about 1 year ago

adding these lines to jobsub_api fixed the http headers problem that I thought earlier was a cherrypy version difference:

#these two have to be explicitly set for apache 2.4 for some reason
    #
RequestHeader set Ssl-Client-S-Dn "%{SSL_CLIENT_S_DN}s"
RequestHeader set Ssl-Client-I-Dn "%{SSL_CLIENT_I_DN}s"

also updated request_headers.py to reformat DN if needed

#3 Updated by Dennis Box about 1 year ago

  • Status changed from New to Work in progress

#4 Updated by Dennis Box about 1 year ago

  • Target version changed from v1.2.8 to v1.2.8.1

#5 Updated by Dennis Box about 1 year ago

  • Target version changed from v1.2.8.1 to v1.2.9

#6 Updated by Dennis Box 11 months ago

  • Target version changed from v1.2.9 to v1.3


Also available in: Atom PDF