Project

General

Profile

Bug #16382

Larsoft geometry does not compile in Root

Added by David Adams over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
05/02/2017
Due date:
% Done:

0%

Estimated time:
1.00 h
Spent time:
Occurs In:
Experiment:
-
Co-Assignees:
Duration:

Description

I am getting error when I try to import v06_34_00 Larsoft geometry into Root. The error log is below. This was working a month or two ago.

Please assign this to me if you would like me to try to fix the problems.

Thank you.
David

Info in <TUnixSystem::ACLiC>: creating shared library /dune/app/users/dladams/dev/dudev02/workdir/srcs/dune_extensions/run/run35tdata/.aclic//nashome/d/dladams/dev/dudev02/workdir/localProducts_larsoft_v06_34_00_e14_prof/dunetpc/v06_34_00/include/dune/DuneServiceAccess/LarsoftServiceAccess_h.so
In file included from input_line_12:9:
In file included from /nashome/d/dladams/dev/dudev02/workdir/localProducts_larsoft_v06_34_00_e14_prof/dunetpc/v06_34_00/include/dune/DuneServiceAccess/LarsoftServiceAccess.h:25:
In file included from /cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_09_01/include/larcore/Geometry/GeometryCore.h:51:
In file included from /cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_09_01/include/larcore/Geometry/TPCGeo.h:17:
In file included from /cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_09_01/include/larcore/Geometry/PlaneGeo.h:17:
/cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_09_01/include/larcore/Geometry/Decomposer.h:515:59: error: 'AffinePlaneBase_t' is a private member of 'geo::PlaneDecomposer<TVector3, TVector3,
ROOT::Math::DisplacementVector2D<ROOT::Math::Cartesian2D<double>, geo::PlaneGeo::WireCoordinateReferenceTag> >'
using AffinePlaneBase_t = typename PlaneDecomposer_t::AffinePlaneBase_t;
^
/cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_09_01/include/larcore/Geometry/PlaneGeo.h:106:36: note: in instantiation of template class 'geo::Decomposer<TVector3, TVector3,
ROOT::Math::DisplacementVector2D<ROOT::Math::Cartesian2D<double>, geo::PlaneGeo::WireCoordinateReferenceTag> >' requested here
using WireDecomposedVector_t = WireDecomposer_t::DecomposedVector_t;
^
/cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_09_01/include/larcore/Geometry/Decomposer.h:280:11: note: implicitly declared private here
using AffinePlaneBase_t = AffinePlaneBase<Vector, Point>;
^
/cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_09_01/include/larcore/Geometry/Decomposer.h:515:59: error: 'AffinePlaneBase_t' is a private member of 'geo::PlaneDecomposer<TVector3, TVector3,
ROOT::Math::DisplacementVector2D<ROOT::Math::Cartesian2D<double>, geo::PlaneGeo::WidthDepthReferenceTag> >'
using AffinePlaneBase_t = typename PlaneDecomposer_t::AffinePlaneBase_t;
^
/cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_09_01/include/larcore/Geometry/PlaneGeo.h:110:34: note: in instantiation of template class 'geo::Decomposer<TVector3, TVector3,
ROOT::Math::DisplacementVector2D<ROOT::Math::Cartesian2D<double>, geo::PlaneGeo::WidthDepthReferenceTag> >' requested here
using WDDecomposedVector_t = WidthDepthDecomposer_t::DecomposedVector_t;
^
/cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_09_01/include/larcore/Geometry/Decomposer.h:280:11: note: implicitly declared private here
using AffinePlaneBase_t = AffinePlaneBase<Vector, Point>;
^
In file included from input_line_12:9:
In file included from /nashome/d/dladams/dev/dudev02/workdir/localProducts_larsoft_v06_34_00_e14_prof/dunetpc/v06_34_00/include/dune/DuneServiceAccess/LarsoftServiceAccess.h:25:
In file included from /cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_09_01/include/larcore/Geometry/GeometryCore.h:51:
/cvmfs/fermilab.opensciencegrid.org/products/larsoft/larcore/v06_09_01/include/larcore/Geometry/TPCGeo.h:627:3: error: 'decltype(auto)' cannot be combined with other type specifiers
decltype(auto) const box = BoundingBox();
^ ~~~~
Error in <ACLiC>: Dictionary generation failed!

Associated revisions

Revision e6f26dbc (diff)
Added by Gianluca Petrillo over 2 years ago

Moved geo::PlaneDecomposer<>::AffinePlaneBase_t to public access.

This solves issue #16382.

Revision 460f5060 (diff)
Added by Gianluca Petrillo over 2 years ago

Moved geo::PlaneDecomposer<>::AffinePlaneBase_t to public access.

This solves issue #16382.

History

#1 Updated by Gianluca Petrillo over 2 years ago

  • Category set to Geometry
  • Status changed from New to Assigned
  • Assignee set to Gianluca Petrillo
  • Estimated time set to 1.00 h
  • Occurs In v06_32_00 added
  • Occurs In deleted (develop/HEAD)

#2 Updated by Gianluca Petrillo over 2 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100
  • Occurs In v06_34_00 added
  • Occurs In deleted (v06_32_00)

AffinePlaneBase_t definition has now been made public, as it should have been since it's part of the interface.
The changes are in develop branch of larcore, in larcore:e6f26dbc9a7cef62dc2b5dd60bae5a9a22b9af9e.
If you don't want to wait for the release (which this commit is likely to miss), patching is straightforward, and with some luck you might cheat the system and avoid rebuilding the depending repositories.
Since you did not give instructions on how to reproduce the problem, I can't verify that this actually solves the problem.
I am marking the issue as resolved for assumption. Please reopen if it is not actually solved.

#3 Updated by Lynn Garren over 2 years ago

This is just in time to be included in the upcoming larsoft bug fix release: v06_34_01.

#4 Updated by David Adams over 2 years ago

  • Category deleted (Geometry)
  • Assignee deleted (Gianluca Petrillo)
  • % Done changed from 100 to 0
  • Occurs In develop/HEAD added
  • Occurs In deleted (v06_34_00)

I will try the new larsoft release when it is available. Thanks. --da

#5 Updated by David Adams over 2 years ago

  • Assignee set to David Adams

I was reminded I should check this. --da



Also available in: Atom PDF