Project

General

Profile

Bug #16377

Error: no plane for view #0 when running linecluster/trajcluster in dual phase geometry

Added by Christoph Alt over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Geometry
Target version:
-
Start date:
05/02/2017
Due date:
% Done:

100%

Estimated time:
Spent time:
Occurs In:
Experiment:
DUNE
Co-Assignees:
Duration:

Description

Hi All,

After installing larsoft v06_33_00 last week, I get the following error in the reconstruction at the stage of linecluster/trajcluster for dual phase geometries (I checked both protodune dual phase and far detector dual phase geometry). Gen, g4, detsim as well as hit finding work fine.

%MSG-s ArtException: PostProcessPath reco 21-Apr-2017 13:24:21 CEST PostProcessEvent
cet::exception caught in art
---- EventProcessorFailure BEGIN
An exception occurred during current event processing
---- ScheduleExecutionFailure BEGIN
ProcessingStopped.

---- TPCGeo BEGIN
TPCGeo[0x6f8c830]::Plane(): no plane for view #0
cet::exception going through module
---- TPCGeo END
Exception going through path reco
---- ScheduleExecutionFailure END
---- EventProcessorFailure END
%MSG

This error didn't occur in v06_31_00 and I haven't checked v06_32_00.

Please let me know if you need any additional information!

Best,
Christoph

History

#1 Updated by Andrea Scarpelli over 3 years ago

I have just checked and the error is still present in version v06_33.

#2 Updated by Gianluca Petrillo over 3 years ago

  • Category set to Geometry
  • Status changed from New to Accepted

It looks like one of the modules you mention is asking for a plane with view kU (0), which your geometry might not have.
To debug this, we need:

  • the branch of larcore, larcoreobj, larreco and dunetpc you are using; if they are not public, please push them as feature branches
  • the name of the FHiCL configuration file you are using
  • an ROOT input file showing the issue, and if large, in which event the error happens (I would expect it to be the first...)

The problem might be at different places. The code to assign views was changed, and it was tested only on the geometries publicly available with tests.

#3 Updated by Gianluca Petrillo over 3 years ago

  • Occurs In v06_32_00 added
  • Occurs In deleted (2017-2-quarter)

#4 Updated by Gianluca Petrillo over 3 years ago

  • Occurs In v06_33_00 added
  • Occurs In deleted (v06_32_00)

#5 Updated by Andrea Scarpelli over 3 years ago

Hi,

I don't know what Christoph is using but in my case the very same error is displayed in the develop branches from v06_33. I am using the standard protodunedp files in the folder dunetpc/fcl/protodunedp. Gen, g4, detsim goes well. the error is displayed in reco while the clustering is made (hits can be reconstructed). No root file is produced because the error is propagated though the reco path.

#6 Updated by Christoph Alt over 3 years ago

The error occurs after a fresh installation of v06_33_00 in the develop branches of larcore, larcoreobj, larreco and dunetpc (without any changes from my side).

The .fcl's I (and Andrea) are using:

1. dune far detector dual phase workspace geometry:

gen: srcs/dunetpc/fcl/dunefd/gen/single/prodsingle_dune10ktdphase.fcl
g4: srcs/dunetpc/fcl/dunefd/g4/standard_g4_dune10kt_dp.fcl
detsim: srcs/dunetpc/fcl/dunefd/detsim/standard_detsim_dune10kt_dp.fcl
reco: srcs/dunetpc/fcl/dunefd/reco/standard_reco_dune10ktdphase.fcl

2. protdune dual phase geometry:

gen: srcs/dunetpc/fcl/protodunedp/gen/prod_protodunedp.fcl
g4: srcs/dunetpc/fcl/protodunedp/g4/standard_g4_protodunedp.fcl
detsim: srcs/dunetpc/fcl/protodunedp/detsim/standard_detsim_protodunedp.fcl
reco: srcs/dunetpc/fcl/protodunedp/reco/standard_reco_protodunedp.fcl

I don't have any files on the fermilab computers, but the error occurs at the stage of linecluster/trajcluster in the reconstruction of the first event (I produce only one muon) for every output file from detsim using the above .fcl's.

#7 Updated by Gianluca Petrillo over 3 years ago

  • Status changed from Accepted to Assigned
  • Assignee set to Gianluca Petrillo
  • Occurs In v06_34_00 added

I can reproduce the problem with develop (using the far detector chain Christoph wrote).

#8 Updated by Gianluca Petrillo over 3 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

The problem is in the hits not being assigned to an existing view. This originates from the channel mapping ("CRM") not being consistent with the geometry.
In fact, the channel mapping view should disappear.
I have updated the channel mapping in a way that should work for the rotated dual phase detector geometries.
I have also fixed other problems related to views (which appeared where view was the wrong concept to use anyway).

So the problem you found is solved (pushed in dunetpc develop branch).

But I am cheating: there is still a problem with PMA, at pma::TrkCandidate pma::PMAlgTracker::matchCluster(). That code seems to hard-code the view names (U, V, Z) not considering that there may be others (X and Y for ICARUS and ProtoDUNE Dual Phase, for example). Running the sequence Christoph has outlined, PMA will trigger an error.
That is matter for another ticket.

#9 Updated by Katherine Lato over 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF