Project

General

Profile

Bug #16326

artdaq-demo installation fails

Added by John Freeman over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Known Issues
Target version:
Start date:
04/25/2017
Due date:
% Done:

50%

Estimated time:
Co-Assignees:
Duration:

Description

On both woof and mu2edaq01, if I try installing artdaq-demo according to our instructions on the wiki (i.e., the installation for v2_09_02), the installation fails. This is not the case with v2_09_01. The actual failure modes differ between woof and mu2edaq01. On mu2edaq01, we get:

----------- check this block for errors -----------------------
ERROR: Version conflict -- dependency tree requires versions conflicting with current setup of product canvas: version v1_04_06 vs v1_06_02
ERROR: setup -B art v2_03_00 -q +e10:+prof failed

and on woof, we get:

The source code directory is /home/jcfree/scratch/artdaq-demo_v2_09_02/srcs
----------- check this block for errors -----------------------
ERROR: Product 'artdaq_core' (with qualifiers 'e10:prof:s46'), has no v1_07_03 version (or may not exist)
ERROR: setup -B artdaq_core v1_07_03 -q +e10:+s46:+prof failed

The full output for the mu2edaq01 installation can be found at mu2edaq01:/home/jcfree/artdaq-demo_v2_09_02/log/quick-mrb-start.sh_Tue_Apr_25_15:38:42.script and the full output for the woof installation can be found at woof:/home/jcfree/scratch/artdaq-demo_v2_09_02/log/quick-mrb-start.sh_Tue_Apr_25_15:38:02.script

Associated revisions

Revision a8e2a42d (diff)
Added by John Freeman over 3 years ago

JCF: update product deps to use artdaq v2_02_02, which uses the same artdaq-core version as artdaq-core-demo (see Issue #16326)

History

#1 Updated by John Freeman over 3 years ago

  • % Done changed from 0 to 50

Certainly ONE of the causes of the failed installation is the dependency tree for artdaq-demo v2_09_02. In a nutshell, according to the ups/product_deps files:

  1. artdaq-demo v2_09_02 depends on artdaq v2_02_01 and artdaq-core-demo v1_06_02
  2. artdaq v2_02_01 depends on artdaq-core v1_07_01
  3. artdaq-core-demo v1_06_02 depends on artdaq-core v1_07_03

..i.e., artdaq and artdaq-core-demo expect different versions of artdaq-core. For the time being, then, I'm simply reverting the instructions on the artdaq-demo wiki to instruct users to install artdaq-demo v2_09_01.

#2 Updated by Eric Flumerfelt over 3 years ago

  • Category set to Known Issues
  • Assignee set to John Freeman
  • Target version set to artdaq-demo v2_09_03

We will ensure that quick-mrb-start.sh works correctly for artdaq-demo v2_09_03.

#3 Updated by Eric Flumerfelt over 3 years ago

  • Status changed from New to Closed


Also available in: Atom PDF