Project

General

Profile

Bug #16291

Bug #16251: problems encountered when building on minsky.fnal.gov

build of lardata fails on minsky

Added by Lynn Garren over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
04/21/2017
Due date:
% Done:

100%

Estimated time:
Spent time:
Scope:
Internal
Experiment:
-
SSI Package:
Co-Assignees:
Duration:

Description

The problem is in a root header.

[ 13%] Building CXX object lardata/RecoObjects/CMakeFiles/lardata_RecoObjects.dir/KFTrackState.cxx.o
In file included from /home/garren/products/root/v6_08_06d/Linuxppc64le64bit+3.10-2.17-e14-nu-prof/include/Math/Dinv.h:344:0,
                 from /home/garren/products/root/v6_08_06d/Linuxppc64le64bit+3.10-2.17-e14-nu-prof/include/Math/SMatrix.icc:49,
                 from /home/garren/products/root/v6_08_06d/Linuxppc64le64bit+3.10-2.17-e14-nu-prof/include/Math/SMatrix.h:741,
                 from /home/garren/products/lardataobj/v1_15_01/include/lardataobj/RecoBase/TrackingTypes.h:10,
                 from /home/garren/products/lardata/v06_20_00/src/lardata/RecoObjects/TrackState.h:,
                 from /home/garren/products/lardata/v06_20_00/src/lardata/RecoObjects/KFTrackState.h:4,
                 from /home/garren/products/lardata/v06_20_00/src/lardata/RecoObjects/KFTrackState.cxx:1:
/home/garren/products/root/v6_08_06d/Linuxppc64le64bit+3.10-2.17-e14-nu-prof/include/Math/MatrixInversion.icc: In static member function ‘static void ROOT::Math::Inverter<idim, n>::InvertBunchKaufman(ROOT::Math::MatRepSym<T, n>&, int&) [with T = double; unsigned int idim = 5u; unsigned int n = 5u]’:
/home/garren/products/root/v6_08_06d/Linuxppc64le64bit+3.10-2.17-e14-nu-prof/include/Math/MatrixInversion.icc:280:35: error: assuming signed overflow does not occur when assuming that (X + c) >= X is always true [-Werror=strict-overflow]
                   for (k = j+2; k <= i ; k++)
                                 ~~^~~~

History

#1 Updated by Lynn Garren over 2 years ago

  • Status changed from New to Resolved
  • Assignee set to Lynn Garren
  • % Done changed from 0 to 100

We think the overflow symantics must be different on this machine.

The problem is resolved by adding a pragma to lardata/RecoObjects/TrackState.h

#pragma GCC diagnostic ignored "-Wstrict-overflow" 

The pragma should really be further upstream on lardataobj/RecoBase/TrackingTypes.h

#2 Updated by Lynn Garren about 1 year ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF