Project

General

Profile

Bug #16261

Bug #16251: problems encountered when building on minsky.fnal.gov

problems encountered when building nutools on minsky

Added by Lynn Garren over 2 years ago. Updated over 2 years ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
04/20/2017
Due date:
% Done:

0%

Estimated time:
Scope:
Internal
Experiment:
-
SSI Package:
Co-Assignees:
Duration:

Description

The gsl tests fail. These are already known to be broken for macOS, so we just disable them.

lhapdf and log4cpp both require newer versions of config.guess and config.sub. See #16255

geant4 is still using a script that calls upd. However, there are problems with upd. This script is unnecessary, so we simply stop using it.

genie uses root-config --arch, which returns linuxppc64gcc. Edit src/make/Make.include to recognize this architecture. Also do not add -lquadmath to the link list.

TRACE fails to find a system header. Suspect that it is trying to build for the wrong architecture. Disable the build of TRACE and artdaq_core. See #16260

History

#1 Updated by Lynn Garren over 2 years ago

  • Status changed from New to Accepted


Also available in: Atom PDF