Project

General

Profile

Bug #16227

problem merging feature/wketchum_ViewAssignment

Added by Lynn Garren over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Geometry
Target version:
-
Start date:
04/17/2017
Due date:
% Done:

100%

Estimated time:
Spent time:
Occurs In:
Experiment:
-
Co-Assignees:
Duration:

Description

dunetpc unit tests test_ExponentialChannelNoiseService and test_Dune35tNoiseRemovalService fail when built against feature/ wketchum_ViewAssignment, which is found in larevt, larcore, larcoreobj and lardata. The problem appears to be the same in both tests.

test_ExponentialChannelNoiseService: -----------------------------
test_ExponentialChannelNoiseService: Create noise service.
ExponentialChannelNoiseService::ctor: WARNING: Using hardwired seed.
ExponentialChannelNoiseService::ctor:   Registered seed: 54321
Info in <TGeoManager::Import>: Reading geometry from file: /scratch/garren/larsoft/v06_32_01/p/build_slf7.x86_64/dunetpc/gdml/dune35t4apa_v5.gdml
Info in <TGeoManager::TGeoManager>: Geometry GDMLImport, Geometry imported from GDML created
Info in <TGeoManager::SetTopVolume>: Top volume is volWorld. Master volume is volWorld
Info in <TGeoNavigator::BuildCache>: --- Maximum geometry depth set to 100
Info in <TGeoManager::CheckGeometry>: Fixing runtime shapes...
Info in <TGeoManager::CheckGeometry>: ...Nothing to fix
Info in <TGeoManager::CloseGeometry>: Counting nodes...
Info in <TGeoManager::Voxelize>: Voxelizing...
Info in <TGeoManager::CloseGeometry>: Building cache...
Info in <TGeoManager::CountLevels>: max level = 5, max placements = 359
Info in <TGeoManager::CloseGeometry>: 5627 nodes/ 2528 volume UID's in Geometry imported from GDML
Info in <TGeoManager::CloseGeometry>: ----------------modeler ready----------------
terminate called after throwing an instance of 'cet::coded_exception<art::errors::ErrorCodes, &art::ExceptionDetail::translate[abi:cxx11]>'
  what():  ---- OtherArt BEGIN
  ServiceCreation
  ---- OtherArt BEGIN
    ServiceCreation
    ---- DuneApaChannelMapAlg BEGIN
      Initialize: View 1 is not the expected 0
    ---- DuneApaChannelMapAlg END
    cet::exception caught during construction of service type geo::Geometry:
  ---- OtherArt END
  cet::exception caught during construction of service type detinfo::DetectorPropertiesServiceStandard:
---- OtherArt END

test_Dune35tNoiseRemovalService: -----------------------------
test_Dune35tNoiseRemovalService: Fetch noise removal.
Info in <TGeoManager::Import>: Reading geometry from file: /scratch/garren/larsoft/v06_32_01/p/build_slf7.x86_64/dunetpc/gdml/dune35t4apa_v5.gdml
Info in <TGeoManager::TGeoManager>: Geometry GDMLImport, Geometry imported from GDML created
Info in <TGeoManager::SetTopVolume>: Top volume is volWorld. Master volume is volWorld
Info in <TGeoNavigator::BuildCache>: --- Maximum geometry depth set to 100
Info in <TGeoManager::CheckGeometry>: Fixing runtime shapes...
Info in <TGeoManager::CheckGeometry>: ...Nothing to fix
Info in <TGeoManager::CloseGeometry>: Counting nodes...
Info in <TGeoManager::Voxelize>: Voxelizing...
Info in <TGeoManager::CloseGeometry>: Building cache...
Info in <TGeoManager::CountLevels>: max level = 5, max placements = 359
Info in <TGeoManager::CloseGeometry>: 5627 nodes/ 2528 volume UID's in Geometry imported from GDML
Info in <TGeoManager::CloseGeometry>: ----------------modeler ready----------------
terminate called after throwing an instance of 'cet::coded_exception<art::errors::ErrorCodes, &art::ExceptionDetail::translate[abi:cxx11]>'
  what():  ---- OtherArt BEGIN
  ServiceCreation
  ---- OtherArt BEGIN
    ServiceCreation
    ---- DuneApaChannelMapAlg BEGIN
      Initialize: View 1 is not the expected 0
    ---- DuneApaChannelMapAlg END
    cet::exception caught during construction of service type geo::Geometry:
  ---- OtherArt END
  cet::exception caught during construction of service type Dune35tNoiseRemovalService:
---- OtherArt END

Related issues

Blocked by dunetpc - Bug #16118: Some DUNE 35t tests exercise an outdated geometryClosed04/06/2017

History

#1 Updated by Gianluca Petrillo over 3 years ago

  • Is duplicate of Bug #16118: Some DUNE 35t tests exercise an outdated geometry added

#2 Updated by Gianluca Petrillo over 3 years ago

  • Category set to Geometry

Those tests have a hard-coded obsolete DUNE 35t geometry and they should be fixed.

The algorithm I developed is expected to be backward-compatible with the current version of all tested geometries by MicroBooNE, LArIAT, DUNE and ArgoNeuT.
DUNE has already stated they have no interest in supporting their v5 geometry (there are very valid reasons why they have a v6).

#3 Updated by Gianluca Petrillo over 3 years ago

  • Is duplicate of deleted (Bug #16118: Some DUNE 35t tests exercise an outdated geometry)

#4 Updated by Gianluca Petrillo over 3 years ago

  • Blocked by Bug #16118: Some DUNE 35t tests exercise an outdated geometry added

#5 Updated by Gianluca Petrillo over 3 years ago

  • Subject changed from problem merging feature/ wketchum_ViewAssignment to problem merging feature/wketchum_ViewAssignment

A temporary solution is to ignore/disable those two tests.

#6 Updated by Lynn Garren over 3 years ago

  • Status changed from New to Resolved
  • Assignee set to Lynn Garren
  • % Done changed from 0 to 100

Fixed in commits 79a5ecbd276d276647f83c0d4b802c93814bb9f7 and 3d27c52889fc7ac59689fa1e0ef5f7fdde5d8e8f. The fixes were confirmed by rebuilding the code and running the tests.

#7 Updated by Lynn Garren over 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF