Project

General

Profile

Bug #16146

Cannot exit gracefully

Added by Will Foreman over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
04/10/2017
Due date:
% Done:

100%

Estimated time:
Spent time:
Occurs In:
Scope:
Internal
Experiment:
LArIAT
SSI Package:
art
Duration:

Description

Hello,

I'm using lariatsoft v06_31_00 on a GPVM, lariatgpvm03.fnal.gov.

In past versions, when I ran LArSoft code interactively ("lar -c ..."), doing "ctrl+C" would initiate the endJob function and my code would exit gracefully and all my nice end-job plots would be made.

This no longer seems to be the case.

Is there a way to recover this functionality? Is this a LArSoft-specific issue?

Thanks,
Will

History

#1 Updated by Will Foreman over 3 years ago

To be more specific, here's an example of output when I do ctrl+C during the running of a module:

...
Begin processing the 948th record. run: 10024 subRun: 1 event: 9797 at 10-Apr-2017 18:11:02 CDT
Begin processing the 949th record. run: 10024 subRun: 1 event: 9798 at 10-Apr-2017 18:11:02 CDT
Begin processing the 950th record. run: 10024 subRun: 1 event: 9799 at 10-Apr-2017 18:11:02 CDT
^CBegin processing the 951st record. run: 10024 subRun: 1 event: 9800 at 10-Apr-2017 18:11:02 CDT
Begin processing the 952nd record. run: 10024 subRun: 1 event: 9801 at 10-Apr-2017 18:11:02 CDT
Begin processing the 953rd record. run: 10024 subRun: 1 event: 9802 at 10-Apr-2017 18:11:02 CDT
Art has handled signal 2.
Art has completed and will exit with status 130.

Seems "signal 2" is what art is mapping as ctrl+C. Hope this helps.

#2 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Kyle Knoepfel

The behavior change you observe is confirmed. It is not a LArSoft-specific issue, but it is a change that was unintentionally introduced in art between versions 2.05.00 and 2.06.00. We will work to restore the original behavior.

#3 Updated by Kyle Knoepfel over 3 years ago

  • Category set to Infrastructure
  • % Done changed from 0 to 50
  • SSI Package art added

The fix to this bug is implemented with art art:68cee7ed. I have marked this issue as 50% complete because the same graceful shutdown behavior must be confirmed in the context of an exception throw.

#4 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 50 to 100

I confirmed that exiting gracefully was also unintentionally removed in the context of an exception throw--i.e. the endSubRun, endRun, and endJob user-provided functions were not called whenever an exception was thrown from an event callback.

This has been fixed with commit art:e9198343. We will create an art 2.06 bug-fix release that incorporates these fixes.

#5 Updated by Kyle Knoepfel over 3 years ago

  • Target version set to 1209

#6 Updated by Kyle Knoepfel over 3 years ago

  • Target version changed from 1209 to 2.07.01

#7 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF