Project

General

Profile

Task #16120

argoneutcode: moving the code to v06_30_00 there is a data product size change in the association art::Assns<recob::Cluster,recob::Vertex,unsigned short>

Added by Vito Di Benedetto over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Other
Target version:
-
Start date:
04/06/2017
Due date:
% Done:

50%

Estimated time:
Spent time:
Duration:

Description

Moving LArSoft from v06_29_00 to v06_30_00 (release notes for v06_30_00 are available here) the CI reported a data product size change for the reco stage of argoneutcode.

The difference between the reco reference file and the current file consist of:

419: < Reco | trajcluster |  | art::Assns<recob::Cluster,recob::Vertex,unsigned short> | 5
420: ---
421: > Reco | trajcluster |  | art::Assns<recob::Cluster,recob::Vertex,unsigned short> | 6

(Lines with "<" show what is in the reference file,
lines with ">" show what is produced by v06_30_00.)

The full stdout log of the reco stage is available at:
http://dbweb6.fnal.gov:8080/LarCI/app/storage/docs/2017/04/05/stdout.log

Looking at the relevant code in larreco, doesn't seems to be a correlated code change that produced this difference in the output.

Dumping the hits (dump_hits.fcl) from the reference (DumpHits_Reference.log) and the current output (DumpHits_Current.log) file, the hits are identical.

Dumping the clusters (dump_clusters.fcl) and the vertices (dump_pfparticles.fcl) there are some differences between the reference (DumpClusters_Reference.log, DumpPFParticles_Current.log) and the current output (DumpClusters_Current.log, DumpPFParticles_Current.log).

The dumper FHiCL files and the logs are attached, the reference and the current output of the argoneutcode reco stage are available at
/pnfs/argoneut/scratch/users/vito/ci_output_files/lar_ci_148_slf6/ci_reco_regression_test_argoneutcode

Some investigation is required to understand why there is this difference in the association of clusters and vertices moving the code from v06_29_00 to v06_30_00.

dump_clusters.fcl (1.89 KB) dump_clusters.fcl Vito Di Benedetto, 04/06/2017 11:37 AM
dump_pfparticles.fcl (3.46 KB) dump_pfparticles.fcl Vito Di Benedetto, 04/06/2017 11:37 AM
DumpClusters_Current.log (2.92 KB) DumpClusters_Current.log Vito Di Benedetto, 04/06/2017 11:37 AM
DumpClusters_Reference.log (2.91 KB) DumpClusters_Reference.log Vito Di Benedetto, 04/06/2017 11:37 AM
dump_hits.fcl (1.8 KB) dump_hits.fcl Vito Di Benedetto, 04/06/2017 11:37 AM
DumpHits_Current.log (61.9 KB) DumpHits_Current.log Vito Di Benedetto, 04/06/2017 11:37 AM
DumpPFParticles_Current.log (868 Bytes) DumpPFParticles_Current.log Vito Di Benedetto, 04/06/2017 11:37 AM
DumpHits_Reference.log (61.9 KB) DumpHits_Reference.log Vito Di Benedetto, 04/06/2017 11:37 AM
DumpPFParticles_Reference.log (858 Bytes) DumpPFParticles_Reference.log Vito Di Benedetto, 04/06/2017 11:37 AM

History

#1 Updated by Lynn Garren over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Gianluca Petrillo

#2 Updated by Gianluca Petrillo over 3 years ago

  • Status changed from Assigned to Work in progress

I can reproduce the issue.

#3 Updated by Gianluca Petrillo over 3 years ago

  • Category set to Other

Actually, no, I can't (any more??).
Running v06_29_00 (larreco and argoneutcode locally compiled) on the ROOT files deprived of the Reco process, I can't reproduce the result of LArSoft 6.29.00.

One wild guess here. Is it possible that this was the effect of an older change, that was missed by the previous C.I. tests because of the bug on the event dumper, which would not print the size of the associations in some art 2.5.x versions?
This is an excerpt of the dump of the reference file, as seen by v06_29_00 (art 2.5.0):

Reco........ | trajcluster... | ..................... | std::vector<recob::Vertex>............................. | ...4
Reco........ | trajcluster... | ..................... | art::Assns<raw::RawDigit,recob::Hit,void>.............. | ...-
Reco........ | trajcluster... | ..................... | art::Assns<recob::Cluster,recob::Hit,void>............. | ...-
Reco........ | trajcluster... | ..................... | art::Assns<recob::PFParticle,recob::Vertex,void>....... | ...-
Reco........ | trajcluster... | ..................... | art::Assns<recob::Wire,recob::Hit,void>................ | ...-
Reco........ | trajcluster... | ..................... | std::vector<recob::Hit>................................ | .226
Reco........ | trajcluster... | ..................... | std::vector<recob::PFParticle>......................... | ...3
Reco........ | trajcluster... | ..................... | art::Assns<recob::Cluster,recob::Vertex,unsigned short> | ...-
Reco........ | trajcluster... | ..................... | art::Assns<recob::PFParticle,recob::Cluster,void>...... | ...-
Reco........ | trajcluster... | ..................... | std::vector<recob::EndPoint2D>......................... | ...2
Reco........ | trajcluster... | ..................... | std::vector<recob::Cluster>............................ | ...7

The same file, seen by v06_30_00 (art 2.6.3):
Reco........ | trajcluster... | ..................... | std::vector<recob::Vertex>............................. | ...4
Reco........ | trajcluster... | ..................... | art::Assns<raw::RawDigit,recob::Hit,void>.............. | .226
Reco........ | trajcluster... | ..................... | art::Assns<recob::Cluster,recob::Hit,void>............. | .216
Reco........ | trajcluster... | ..................... | art::Assns<recob::PFParticle,recob::Vertex,void>....... | ...3
Reco........ | trajcluster... | ..................... | art::Assns<recob::Wire,recob::Hit,void>................ | .226
Reco........ | trajcluster... | ..................... | std::vector<recob::Hit>................................ | .226
Reco........ | trajcluster... | ..................... | std::vector<recob::PFParticle>......................... | ...3
Reco........ | trajcluster... | ..................... | art::Assns<recob::Cluster,recob::Vertex,unsigned short> | ...5
Reco........ | trajcluster... | ..................... | art::Assns<recob::PFParticle,recob::Cluster,void>...... | ...6
Reco........ | trajcluster... | ..................... | std::vector<recob::EndPoint2D>......................... | ...2
Reco........ | trajcluster... | ..................... | std::vector<recob::Cluster>............................ | ...7

#4 Updated by Gianluca Petrillo over 3 years ago

  • % Done changed from 0 to 50

Note that the relevance of this ticket is to determine if some unexpected bug is present in art from 2.5 to 2.6.
If both the following are true:

  1. the C.I. test can't be relied on having noticed a change in association result before LArSoft 6.29.00
  2. with LArSoft 6.29.00 we can regenerate a reference-like file which matches the output of LArSoft 6.30.00 (as my tests suggests)

then I think it's fair to dismiss the issue as a likely false positive. Further confirmation of the second point would be if "reference files" could be generated with v06_29_00, which I expect would show the same output as v06_30_00.

#5 Updated by Gianluca Petrillo over 3 years ago

  • Status changed from Work in progress to Closed

No updates in a while, and the relevance of this issue has been faded away.
Closing.



Also available in: Atom PDF