Project

General

Profile

Bug #16065

ROOT 6 creates wrong I/O dictionary code when the namespace "next" is used.

Added by Paul Lebrun over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
High
Target version:
Start date:
04/04/2017
Due date:
% Done:

100%

Estimated time:
Spent time:
Scope:
External
Experiment:
NEXT
SSI Package:
Co-Assignees:
Duration:

History

#1 Updated by Christopher Green over 3 years ago

  • Subject changed from CERn root 6 create wrong I/O dictionary code when the namespace "next" is used. to ROOT 6 creates wrong I/O dictionary code when the namespace "next" is used.
  • Description updated (diff)
  • Status changed from New to Assigned
  • Assignee set to Christopher Green
  • Scope changed from Internal to External
  • Experiment NEXT added
  • Experiment deleted (-)

From Philippe:

The 'cause' is of this problem is some internal routine (LookupHelper's short path) does not handle properly the fact that there is an ambiguity (in some context that affects this code path) between the namespace 'next' and the function std::next. A fix should follow shortly.

#2 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

This is not a bug with art, but we will send updates to this issue as we are notified of changes in ROOT that deal with this problem.

#3 Updated by Christopher Green about 3 years ago

This bug has been found and fixed in ROOT by Philippe on all relevant branches. It should be in ROOT 6.08/08, or the next patched UPS package for v6_08_06.

#4 Updated by Kyle Knoepfel about 3 years ago

  • Target version set to 1209

#5 Updated by Kyle Knoepfel about 3 years ago

  • Target version changed from 1209 to 2.07.01

#6 Updated by Kyle Knoepfel about 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF